summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-08-28 18:36:49 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:16 -0300
commitb52932ca834e77fda709c26428f0111642bb50e7 (patch)
treea1863c51a30038f92d5d742a15527c2b9c86f94d /recipes-kernel/kernel-modules
parent754f52d45216e6349ba4511b9fc18c71be590591 (diff)
downloadmeta-freescale-b52932ca834e77fda709c26428f0111642bb50e7.tar.gz
rename ar to kernel-module-ar and move bb to kernel-modules subdir
* rename ar to kernel-module-ar * move bb file to the common kernel-modules subdirectory Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-ar_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-ar_git.bb b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
new file mode 100644
index 00000000..0cfbddf5
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-ar_git.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Auto Response Control Module"
2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
4
5inherit module
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/auto-resp.git;branch=sdk-v1.7.x"
8SRCREV = "dbede76fb4020a370baa393f7c53af4c0db8f175"
9
10S = "${WORKDIR}/git"
11
12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
13export KERNEL_PATH
14
15INHIBIT_PACKAGE_STRIP = "1"
16
17do_compile_prepend() {
18 sed -i -e 's,EXTRA_CFLAGS += -I$(PWD),EXTRA_CFLAGS += -I${S},' ${S}/armodule/source/Makefile
19}
20
21do_install(){
22 install -d ${D}/lib/modules/${KERNEL_VERSION}
23 install -d ${D}${bindir}
24 install -m 644 ${B}/bin/ar.ko ${D}/lib/modules/${KERNEL_VERSION}/
25 cp -f ${S}/bin/ar_* ${D}${bindir}/
26}
27
28FILES_${PN} += "${bindir}/"
29
30COMPATIBLE_MACHINE = "(t1040rdb|t1040rdb-64b|t1042rdb|t1042rdb-64b|t1042rdb-pi|t1042rdb-pi-64b)"