summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules
diff options
context:
space:
mode:
authorPierre-Jean Texier <texier.pj2@gmail.com>2021-11-03 22:10:20 +0100
committerPierre-Jean Texier <texier.pj2@gmail.com>2021-11-03 22:27:01 +0100
commitbef00d6e4f25b4a9d3272e0d69db7545590ed204 (patch)
tree93ee6b4fb459a7719aae1f3010d8c5d65be3e2b2 /recipes-kernel/kernel-modules
parent16e922408678425a492bd109350cd217a0841280 (diff)
downloadmeta-freescale-bef00d6e4f25b4a9d3272e0d69db7545590ed204.tar.gz
recipes: use https protocol and add explicit branch parameter
Due to https://github.blog/2021-09-01-improving-git-protocol-security-github/#no-more-unauthenticated-git it is required to use https protocol for github repo accessing. Update created with oe-core/scripts/contrib/convert-srcuri.py (see [0]) Fixes: WARNING: /work/meta-freescale/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb: URL: git://github.com/Freescale/u-boot-fslc.git;branch=2021.07+fslc uses git protocol which is no longer supported by github. Please change to ;protocol=https in the url. [0] - https://git.openembedded.org/openembedded-core/tree/scripts/contrib/convert-srcuri.py Signed-off-by: Pierre-Jean Texier <texier.pj2@gmail.com>
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb2
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb2
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.15.0.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
index af0b2d60..3e3f8aff 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
10PV .= "+git${SRCPV}" 10PV .= "+git${SRCPV}"
11 11
12SRCREV = "f2e8483fbda59bf2482f77efb0804c014848f749" 12SRCREV = "f2e8483fbda59bf2482f77efb0804c014848f749"
13SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https" 13SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https;branch=master"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb
index 343cce41..996e8262 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.2.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171d
9 9
10SRCBRANCH = "lf-5.10.y" 10SRCBRANCH = "lf-5.10.y"
11LOCALVERSION = "-5.10.52-2.1.0" 11LOCALVERSION = "-5.10.52-2.1.0"
12KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https" 12KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=master"
13SRC_URI = " \ 13SRC_URI = " \
14 ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \ 14 ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
15 file://Add-makefile.patch \ 15 file://Add-makefile.patch \
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.15.0.bb b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.15.0.bb
index f003da18..df97f8b9 100644
--- a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.15.0.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.15.0.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/git/vvcam/LICENSE;md5=64381a6ea83b48c39fe524c85f65fb44" 5LIC_FILES_CHKSUM = "file://${WORKDIR}/git/vvcam/LICENSE;md5=64381a6ea83b48c39fe524c85f65fb44"
6 6
7SRCBRANCH = "lf-5.10.52_2.1.0" 7SRCBRANCH = "lf-5.10.52_2.1.0"
8ISP_KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/isp-vvcam.git;protocol=https" 8ISP_KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/isp-vvcam.git;protocol=https;branch=master"
9 9
10SRC_URI = " \ 10SRC_URI = " \
11 ${ISP_KERNEL_SRC};branch=${SRCBRANCH} \ 11 ${ISP_KERNEL_SRC};branch=${SRCBRANCH} \