summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2018-06-14 16:12:15 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-06-26 14:16:13 -0300
commitdff0ff3ebee7e27840fcfa8d447e864e6c6b16fc (patch)
tree6f90bd686b6d006c1a803c7a99d7e739db6657bb /recipes-kernel/kernel-modules
parent7e1c58cf9bdcefdf39d69669726e5505a082d5c3 (diff)
downloadmeta-freescale-dff0ff3ebee7e27840fcfa8d447e864e6c6b16fc.tar.gz
kernel-module-imx-gpu-viv: Update to 6.2.4.p1.2
As NXP does not offer a specific repository for the kernel-module, this uses the Linux kernel repository and adds a Makefile on top of it. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch326
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p8.6.bb19
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.2.p0.bb16
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.2.bb26
4 files changed, 352 insertions, 35 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
new file mode 100644
index 00000000..63f408c5
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/Add-makefile.patch
@@ -0,0 +1,326 @@
1Index: git/Makefile
2===================================================================
3--- /dev/null 1970-01-01 00:00:00.000000000 +0000
4+++ git/Makefile 2017-06-27 12:07:11.931698672 -0500
5@@ -0,0 +1,17 @@
6+obj-m := galcore.o
7+
8+SRC := $(shell pwd)
9+
10+all:
11+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)/src AQROOT=${PWD}/src
12+ cp $(SRC)/src/Module.symvers $(PWD)
13+ cp $(SRC)/src/modules.order $(PWD)
14+
15+modules_install:
16+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)/src modules_install
17+
18+clean:
19+ find . -name '*.o' -delete
20+ rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
21+ rm -f Module.markers Module.symvers modules.order
22+ rm -rf .tmp_versions Modules.symvers
23Index: git/src/hal/kernel/arch/makefile.linux
24===================================================================
25--- /dev/null 1970-01-01 00:00:00.000000000 +0000
26+++ git/src/hal/kernel/arch/makefile.linux 2017-06-27 11:44:06.004826232 -0500
27@@ -0,0 +1,91 @@
28+##############################################################################
29+#
30+# The MIT License (MIT)
31+#
32+# Copyright (c) 2014 - 2017 Vivante Corporation
33+#
34+# Permission is hereby granted, free of charge, to any person obtaining a
35+# copy of this software and associated documentation files (the "Software"),
36+# to deal in the Software without restriction, including without limitation
37+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
38+# and/or sell copies of the Software, and to permit persons to whom the
39+# Software is furnished to do so, subject to the following conditions:
40+#
41+# The above copyright notice and this permission notice shall be included in
42+# all copies or substantial portions of the Software.
43+#
44+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
45+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
46+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
47+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
48+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
49+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
50+# DEALINGS IN THE SOFTWARE.
51+#
52+##############################################################################
53+#
54+# The GPL License (GPL)
55+#
56+# Copyright (C) 2014 - 2017 Vivante Corporation
57+#
58+# This program is free software; you can redistribute it and/or
59+# modify it under the terms of the GNU General Public License
60+# as published by the Free Software Foundation; either version 2
61+# of the License, or (at your option) any later version.
62+#
63+# This program is distributed in the hope that it will be useful,
64+# but WITHOUT ANY WARRANTY; without even the implied warranty of
65+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
66+# GNU General Public License for more details.
67+#
68+# You should have received a copy of the GNU General Public License
69+# along with this program; if not, write to the Free Software Foundation,
70+# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
71+#
72+##############################################################################
73+#
74+# Note: This software is released under dual MIT and GPL licenses. A
75+# recipient may use this file under the terms of either the MIT license or
76+# GPL License. If you wish to use only one license not the other, you can
77+# indicate your decision by deleting one of the above license notices in your
78+# version of this file.
79+#
80+##############################################################################
81+
82+
83+#
84+# Linux build file for architecture dependent kernel HAL layer.
85+#
86+
87+################################################################################
88+# Include common definitions.
89+
90+include $(AQROOT)/makefile.linux.def
91+
92+################################################################################
93+# Define a shortcut for the main target.
94+
95+STATIC = 1
96+TARGET_NAME = libhalarchkernel.a
97+
98+################################################################################
99+# Supply additional include directories.
100+
101+INCLUDE += -I$(AQROOT)/hal/kernel/inc
102+INCLUDE += -I$(AQROOT)/hal/kernel/inc
103+INCLUDE += -I$(AQROOT)/hal/kernel
104+INCLUDE += -I$(AQROOT)/hal/kernel/arch
105+ifeq ($(VIVANTE_ENABLE_VG),1)
106+INCLUDE += -I$(AQROOT)/hal/kernel/archvg
107+endif
108+
109+CFLAGS += $(INCLUDE) -Werror -ansi
110+
111+
112+################################################################################
113+# Describe object files.
114+
115+OBJECTS = $(OBJ_DIR)/gc_hal_kernel_context.o \
116+ $(OBJ_DIR)/gc_hal_kernel_hardware.o
117+
118+include $(AQROOT)/common.target
119Index: git/src/hal/kernel/archvg/makefile.linux
120===================================================================
121--- /dev/null 1970-01-01 00:00:00.000000000 +0000
122+++ git/src/hal/kernel/archvg/makefile.linux 2017-06-27 11:44:06.004826232 -0500
123@@ -0,0 +1,91 @@
124+##############################################################################
125+#
126+# The MIT License (MIT)
127+#
128+# Copyright (c) 2014 - 2017 Vivante Corporation
129+#
130+# Permission is hereby granted, free of charge, to any person obtaining a
131+# copy of this software and associated documentation files (the "Software"),
132+# to deal in the Software without restriction, including without limitation
133+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
134+# and/or sell copies of the Software, and to permit persons to whom the
135+# Software is furnished to do so, subject to the following conditions:
136+#
137+# The above copyright notice and this permission notice shall be included in
138+# all copies or substantial portions of the Software.
139+#
140+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
141+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
142+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
143+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
144+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
145+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
146+# DEALINGS IN THE SOFTWARE.
147+#
148+##############################################################################
149+#
150+# The GPL License (GPL)
151+#
152+# Copyright (C) 2014 - 2017 Vivante Corporation
153+#
154+# This program is free software; you can redistribute it and/or
155+# modify it under the terms of the GNU General Public License
156+# as published by the Free Software Foundation; either version 2
157+# of the License, or (at your option) any later version.
158+#
159+# This program is distributed in the hope that it will be useful,
160+# but WITHOUT ANY WARRANTY; without even the implied warranty of
161+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
162+# GNU General Public License for more details.
163+#
164+# You should have received a copy of the GNU General Public License
165+# along with this program; if not, write to the Free Software Foundation,
166+# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
167+#
168+##############################################################################
169+#
170+# Note: This software is released under dual MIT and GPL licenses. A
171+# recipient may use this file under the terms of either the MIT license or
172+# GPL License. If you wish to use only one license not the other, you can
173+# indicate your decision by deleting one of the above license notices in your
174+# version of this file.
175+#
176+##############################################################################
177+
178+
179+#
180+# Linux build file for architecture dependent kernel HAL layer.
181+#
182+
183+################################################################################
184+# Include common definitions.
185+
186+include $(AQROOT)/makefile.linux.def
187+
188+################################################################################
189+# Define a shortcut for the main target.
190+
191+STATIC = 1
192+
193+TARGET_NAME = libhalarchkernelvg.a
194+
195+################################################################################
196+# Supply additional include directories.
197+
198+INCLUDE += -I$(AQROOT)/hal/inc
199+INCLUDE += -I$(AQROOT)/hal/user
200+INCLUDE += -I$(AQROOT)/hal/kernel
201+INCLUDE += -I$(AQROOT)/hal/kernel/arch
202+ifeq ($(VIVANTE_ENABLE_VG), 1)
203+INCLUDE += -I$(AQROOT)/hal/kernel/archvg
204+endif
205+
206+CFLAGS += $(INCLUDE) -Werror -ansi
207+
208+################################################################################
209+# Describe object files.
210+
211+OBJECTS = $(OBJ_DIR)/gc_hal_kernel_hardware_vg.o \
212+ $(OBJ_DIR)/gc_hal_kernel_hardware_command_vg.o
213+
214+include $(AQROOT)/common.target
215Index: git/src/hal/kernel/makefile.linux
216===================================================================
217--- /dev/null 1970-01-01 00:00:00.000000000 +0000
218+++ git/src/hal/kernel/makefile.linux 2017-06-27 11:44:06.004826232 -0500
219@@ -0,0 +1,107 @@
220+##############################################################################
221+#
222+# The MIT License (MIT)
223+#
224+# Copyright (c) 2014 - 2017 Vivante Corporation
225+#
226+# Permission is hereby granted, free of charge, to any person obtaining a
227+# copy of this software and associated documentation files (the "Software"),
228+# to deal in the Software without restriction, including without limitation
229+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
230+# and/or sell copies of the Software, and to permit persons to whom the
231+# Software is furnished to do so, subject to the following conditions:
232+#
233+# The above copyright notice and this permission notice shall be included in
234+# all copies or substantial portions of the Software.
235+#
236+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
237+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
238+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
239+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
240+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
241+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
242+# DEALINGS IN THE SOFTWARE.
243+#
244+##############################################################################
245+#
246+# The GPL License (GPL)
247+#
248+# Copyright (C) 2014 - 2017 Vivante Corporation
249+#
250+# This program is free software; you can redistribute it and/or
251+# modify it under the terms of the GNU General Public License
252+# as published by the Free Software Foundation; either version 2
253+# of the License, or (at your option) any later version.
254+#
255+# This program is distributed in the hope that it will be useful,
256+# but WITHOUT ANY WARRANTY; without even the implied warranty of
257+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
258+# GNU General Public License for more details.
259+#
260+# You should have received a copy of the GNU General Public License
261+# along with this program; if not, write to the Free Software Foundation,
262+# Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
263+#
264+##############################################################################
265+#
266+# Note: This software is released under dual MIT and GPL licenses. A
267+# recipient may use this file under the terms of either the MIT license or
268+# GPL License. If you wish to use only one license not the other, you can
269+# indicate your decision by deleting one of the above license notices in your
270+# version of this file.
271+#
272+##############################################################################
273+
274+
275+#
276+# Linux build file for architecture dependent kernel HAL layer.
277+#
278+#
279+
280+
281+################################################################################
282+# Include common definitions.
283+
284+include $(AQROOT)/makefile.linux.def
285+
286+################################################################################
287+# Define a shortcut for the main target.
288+
289+STATIC = 1
290+TARGET_NAME = libhalkernel.a
291+
292+################################################################################
293+# Supply additional include directories.
294+
295+INCLUDE += -I$(AQROOT)/hal/kernel/inc
296+INCLUDE += -I$(AQROOT)/hal/kernel/inc
297+INCLUDE += -I$(AQROOT)/hal/kernel/arch
298+INCLUDE += -I$(AQROOT)/hal/kernel
299+ifeq ($(VIVANTE_ENABLE_VG),1)
300+INCLUDE += -I$(AQROOT)/hal/kernel/archvg
301+endif
302+INCLUDE += -I$(AQROOT)/hal/os/linux/kernel
303+CFLAGS += $(INCLUDE) -Werror -ansi
304+
305+
306+################################################################################
307+# Describe object files.
308+
309+OBJECTS = $(OBJ_DIR)/gc_hal_kernel_command.o \
310+ $(OBJ_DIR)/gc_hal_kernel_db.o \
311+ $(OBJ_DIR)/gc_hal_kernel_debug.o \
312+ $(OBJ_DIR)/gc_hal_kernel_event.o \
313+ $(OBJ_DIR)/gc_hal_kernel_heap.o \
314+ $(OBJ_DIR)/gc_hal_kernel.o \
315+ $(OBJ_DIR)/gc_hal_kernel_mmu.o \
316+ $(OBJ_DIR)/gc_hal_kernel_video_memory.o
317+
318+ifeq ($(VIVANTE_ENABLE_VG),1)
319+OBJECTS += \
320+ $(OBJ_DIR)/gc_hal_kernel_command_vg.o \
321+ $(OBJ_DIR)/gc_hal_kernel_interrupt_vg.o \
322+ $(OBJ_DIR)/gc_hal_kernel_mmu_vg.o \
323+ $(OBJ_DIR)/gc_hal_kernel_vg.o
324+endif
325+
326+include $(AQROOT)/common.target
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p8.6.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p8.6.bb
deleted file mode 100644
index 6c9089f7..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p8.6.bb
+++ /dev/null
@@ -1,19 +0,0 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2
3SUMMARY = "Kernel loadable module for Vivante GPU"
4DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
5allowing flexibility to use an older kernel with a newer graphics release."
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz"
10SRC_URI[md5sum] = "ed31740763b2aa6d56ecbe64d9cea565"
11SRC_URI[sha256sum] = "3e748fc53ee46ffcf80b94d5f9535c58a3875aa107a3c77b550d8100df15de4f"
12
13do_install_prepend() {
14 install ${B}/kernel-module-imx-gpu-viv-src/Module.symvers ${B}
15}
16
17inherit module
18
19KERNEL_MODULE_AUTOLOAD = "galcore"
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.2.p0.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.2.p0.bb
deleted file mode 100644
index 8bf61dca..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.2.p0.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright 2017 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use an older kernel with a newer graphics release."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
9
10SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz"
11SRC_URI[md5sum] = "c5922730046c159fd5055ad114e027b9"
12SRC_URI[sha256sum] = "01b13fa5e1ab69475ce401e997fe8e42775b7792b1233e871b2b28555f8a3a66"
13
14inherit module
15
16KERNEL_MODULE_AUTOLOAD = "galcore"
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.2.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.2.bb
new file mode 100644
index 00000000..2e59a607
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p1.2.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright 2017-2018 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
9
10SRCBRANCH = "imx_4.9.88_2.0.0_ga"
11LOCALVERSION = "-${SRCBRANCH}"
12
13KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https"
14SRC_URI = " \
15 ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
16 file://Add-makefile.patch \
17"
18SRCREV = "5e23f9d6114784d77fd4ed5848953356c3575532"
19
20S = "${WORKDIR}/git"
21
22inherit module
23
24EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
25
26KERNEL_MODULE_AUTOLOAD = "galcore"