summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-10-15 13:52:46 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-10-21 09:07:06 -0300
commitb52c7a789b9a5ff7f8fe382ba8c93f9bb12a491c (patch)
tree641aa4502343b09c84d5d9036de5613f32a0f7c2 /recipes-kernel/kernel-modules
parentf29ce8ff0cd3ee61ddbbc897227bed2e70933323 (diff)
downloadmeta-freescale-b52c7a789b9a5ff7f8fe382ba8c93f9bb12a491c.tar.gz
kernel-module-qoriq-gpu: add recipes
*include the following changes: 7034b39 - update driver to support linux v5.2.0 2c48523 - gpu-module: Add license file aae96e8 - gpu: fix install issue in makefile b8a4405 - gpu: create repository for GPU kernel source code Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qoriq-gpu/0001-Makfile-add-modules_install.patch26
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-qoriq-gpu_git.bb21
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-qoriq-gpu/0001-Makfile-add-modules_install.patch b/recipes-kernel/kernel-modules/kernel-module-qoriq-gpu/0001-Makfile-add-modules_install.patch
new file mode 100644
index 00000000..eb9740f3
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-qoriq-gpu/0001-Makfile-add-modules_install.patch
@@ -0,0 +1,26 @@
1From 2fde2419acc8d89ec26c635a94c180899dbaa293 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Thu, 19 Sep 2019 05:27:11 +0200
4Subject: [PATCH] Makfile: add modules_install
5
6Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
7---
8 Makefile | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/Makefile b/Makefile
12index b67fad7..b386b39 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -191,7 +191,7 @@ clean:
16 @find $(AQROOT) -name ".gc_*.cmd" | xargs rm -f
17 @find $(AQROOT) -name "*.o" | xargs rm -f
18
19-install:
20+modules_install:
21 $(MAKE) -C $(KERNEL_DIR) M=$(PWD) modules_install
22
23 else
24--
252.7.4
26
diff --git a/recipes-kernel/kernel-modules/kernel-module-qoriq-gpu_git.bb b/recipes-kernel/kernel-modules/kernel-module-qoriq-gpu_git.bb
new file mode 100644
index 00000000..e9fd783a
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-qoriq-gpu_git.bb
@@ -0,0 +1,21 @@
1SECTION = "devel"
2SUMMARY = "GPU KERNEL MODULE"
3DESCRIPTION = "The gpu-modules package contains the gpu kernel modules"
4LICENSE = "GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5ab1a30d0cd181e3408077727ea5a2db \
6 "
7inherit module fsl-eula-unpack
8
9SRC_URI = "http://www.nxp.com/lgfiles/sdk/lsdk1909/gpu-module-lsdk1909.bin;;fsl-eula=true \
10 file://0001-Makfile-add-modules_install.patch \
11 "
12SRC_URI[md5sum] = "9f9591530fe7b3f46361bb932901c509"
13SRC_URI[sha256sum] = "8be4ab0d817e66ef685a6a8f3d95ec1e70e9eae73b4f5a836b4b60ebcf0d588d"
14
15S = "${WORKDIR}/gpu-module-lsdk1909"
16
17export INSTALL_MOD_DIR="kernel/gpu-modules"
18
19EXTRA_OEMAKE += "KERNEL_DIR='${STAGING_KERNEL_DIR}'"
20
21COMPATIBLE_MACHINE = "(qoriq)"