summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-01-10 08:34:31 -0300
committerGitHub <noreply@github.com>2023-01-10 08:34:31 -0300
commit1cfd9c034ea323f198f1bfadd74f589ffa3cc061 (patch)
tree0d470d8a9dee5406ca3800e9252af4b9a910ae2f /recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb
parentaf4f812d7a899f96f3aba7b6d66f78cb1a6fec8f (diff)
parente2c4b9b9fa9a2bccdf8a9a6b030112103e41052d (diff)
downloadmeta-freescale-1cfd9c034ea323f198f1bfadd74f589ffa3cc061.tar.gz
Merge pull request #1372 from Freescale/backport-1366-to-kirkstone
[Backport kirkstone] Update Graphics libs to LF5.15.71_2.2.0
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb
new file mode 100644
index 00000000..abb7b323
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright (C) 2017-2021 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
9
10SRC_URI = "${KERNEL_SRC};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
11 file://Add-makefile.patch"
12KERNEL_SRC ?= "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
13SRCBRANCH = "lf-5.15.y"
14LOCALVERSION = "-5.15.71-2.2.0"
15SRCREV = "b257903e33d78d7658ea2a5697fd11044a7b1770"
16
17S = "${WORKDIR}/git"
18
19inherit module
20
21EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
22
23KERNEL_MODULE_AUTOLOAD = "galcore"
24COMPATIBLE_MACHINE = "(imx-nxp-bsp)"