summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb
diff options
context:
space:
mode:
authorGary Bisson <gary.bisson@boundarydevices.com>2023-01-05 11:33:54 +0100
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2023-01-08 18:12:47 +0000
commitf71672627450b711d26bfe3306313476cc48bfcb (patch)
tree1d48c986da5b9bd093028dd664bb579ef271b764 /recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb
parentc70eb3b12ecdeac2a8fe76ff621282eda8c39882 (diff)
downloadmeta-freescale-f71672627450b711d26bfe3306313476cc48bfcb.tar.gz
kernel-module-imx-gpu-viv: upgrade from 6.4.3.p4.4 to 6.4.3.p4.6
Update to the version used in NXP Yocto branch kirkstone-5.15.71-2.2.0. Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> (cherry picked from commit e84194d5655cf1f69241085f64cd3d802fc2ff6a)
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb
new file mode 100644
index 00000000..abb7b323
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.6.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright (C) 2017-2021 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
9
10SRC_URI = "${KERNEL_SRC};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
11 file://Add-makefile.patch"
12KERNEL_SRC ?= "git://github.com/nxp-imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
13SRCBRANCH = "lf-5.15.y"
14LOCALVERSION = "-5.15.71-2.2.0"
15SRCREV = "b257903e33d78d7658ea2a5697fd11044a7b1770"
16
17S = "${WORKDIR}/git"
18
19inherit module
20
21EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
22
23KERNEL_MODULE_AUTOLOAD = "galcore"
24COMPATIBLE_MACHINE = "(imx-nxp-bsp)"