summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-08-18 15:10:47 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2021-08-18 15:13:36 -0500
commitbcc9e436bd3b705701268512fb152ed3c2fc1abe (patch)
tree74cf72b9bc8201fd94c9475736cf43cd80213a5a /recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.0.bb
parent37e29f13214ed190a0ebaf1bb12af17f479a52d3 (diff)
downloadmeta-freescale-bcc9e436bd3b705701268512fb152ed3c2fc1abe.tar.gz
kernel-module-imx-gpu-viv: Upgrade to 6.4.3.p2.0
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.0.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.0.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.0.bb
new file mode 100644
index 00000000..e113aff7
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.0.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright (C) 2017-2021 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
9
10SRCBRANCH = "lf-5.10.y"
11LOCALVERSION = "-5.10.35-2.0.0"
12KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https"
13SRC_URI = " \
14 ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
15 file://Add-makefile.patch \
16"
17SRCREV = "5b2559d9d66b0b9561fc42dd8007dfe4569573df"
18
19S = "${WORKDIR}/git"
20
21inherit module
22
23EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
24
25KERNEL_MODULE_AUTOLOAD = "galcore"
26COMPATIBLE_MACHINE = "(imx)"