summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-08-19 08:21:52 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-23 23:42:37 -0300
commit38c0ed98c1346e85da7f43211e781fa929b1792c (patch)
tree9089ca6b5250224b3229608d64209bfbf131e0ab /recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4.bb
parentb0fefb3813bb69e1714c4dbc30cb066771583389 (diff)
downloadmeta-freescale-38c0ed98c1346e85da7f43211e781fa929b1792c.tar.gz
kernel-module-imx-gpu-viv: upgrade to 6.4.0.p2.4
Align with NXP release imx_5.4.24_2.1.0 Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4.bb
new file mode 100644
index 00000000..7d8d0386
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright (C) 2017-2020 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
9
10SRCBRANCH = "imx_5.4.24_2.1.0"
11LOCALVERSION = "-${SRCBRANCH}"
12KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https"
13SRC_URI = " \
14 ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
15 file://Add-makefile.patch \
16"
17SRCREV = "2f6f3e92a82e51fe39b53ee758273bef26964836"
18
19S = "${WORKDIR}/git"
20
21inherit module
22
23EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
24
25KERNEL_MODULE_AUTOLOAD = "galcore"
26COMPATIBLE_MACHINE = "(imx)"