summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-04-13 20:48:45 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-16 10:32:45 -0300
commit0e967a2d630f318cc218bf468a50194c7ca47b32 (patch)
tree03fafe71caa3f7c4bcad5bd57522195d75357eb4 /recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb
parentbed6e924ec0f65ed5b86935b995c2c110c64addc (diff)
downloadmeta-freescale-0e967a2d630f318cc218bf468a50194c7ca47b32.tar.gz
kernel-module-imx-gpu-viv: upgrade to 6.4.0.p2
Upgrade kernel module version to next p2 stepping as it is aligned in the linux-imx source tree and matches the new kernel 5.4.3-1.0.0 version. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb
new file mode 100644
index 00000000..4c9015e9
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright 2017-2018 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
9
10SRCBRANCH = "lf-5.4.y"
11LOCALVERSION = "-${SRCBRANCH}"
12KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https"
13SRC_URI = " \
14 ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
15 file://Add-makefile.patch \
16"
17SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466"
18
19S = "${WORKDIR}/git"
20
21inherit module
22
23EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
24
25KERNEL_MODULE_AUTOLOAD = "galcore"
26COMPATIBLE_MACHINE = "(imx)"