summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p4.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2019-05-13 19:59:51 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2019-09-12 14:45:07 -0300
commit4cc63839f0f8df6991c7d2968bd17fa27381369b (patch)
tree0b260d274c6b130a6e2c8425c4a60a3011e37400 /recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p4.0.bb
parent085bbd69f3b3612a279dc206098284be6b835f2d (diff)
downloadmeta-freescale-4cc63839f0f8df6991c7d2968bd17fa27381369b.tar.gz
kernel-module-imx-gpu-viv: Upgrade to 6.2.4.p4.0
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p4.0.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p4.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p4.0.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p4.0.bb
new file mode 100644
index 00000000..61fc98e0
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.2.4.p4.0.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2015-2016 Freescale Semiconductor
2# Copyright 2017-2018 NXP
3
4SUMMARY = "Kernel loadable module for Vivante GPU"
5DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
6allowing flexibility to use a newer graphics release with an older kernel."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
9
10SRCBRANCH = "imx_4.14.98_2.0.0_ga"
11LOCALVERSION = "-${SRCBRANCH}"
12KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https"
13SRC_URI = " \
14 ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
15 file://Add-makefile.patch \
16"
17SRCREV = "f54dc1486d13d44766cdb6551d094313f077b535"
18
19S = "${WORKDIR}/git"
20
21inherit module
22
23EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
24
25KERNEL_MODULE_AUTOLOAD = "galcore"
26COMPATIBLE_MACHINE = "(imx)"