summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/ipc/ipc-modules.inc
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-kernel/ipc/ipc-modules.inc
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/ipc/ipc-modules.inc')
-rw-r--r--recipes-kernel/ipc/ipc-modules.inc26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/ipc/ipc-modules.inc b/recipes-kernel/ipc/ipc-modules.inc
new file mode 100644
index 00000000..79ba7ef1
--- /dev/null
+++ b/recipes-kernel/ipc/ipc-modules.inc
@@ -0,0 +1,26 @@
1SUMMARY = "Linux IPC KERNEL MODULE "
2DESCRIPTION = "DSP boot application and ipc test application"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
5
6require recipes-bsp/ipc/ipc.inc
7
8inherit module qoriq_build_64bit_kernel
9
10S = "${WORKDIR}/git"
11
12do_configure[depends] += "virtual/kernel:do_shared_workdir"
13do_configure_prepend() {
14 sed -i 's,$(KERNEL_DIR)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/kernel/Makefile
15}
16
17do_compile_prepend () {
18 cd ${S}/kernel
19 case ${MACHINE} in
20 bsc9132qds|bsc9131rdb) SOC=B913x;;
21 b4860qds|b4420qds) SOC=B4860;;
22 esac
23}
24
25INHIBIT_PACKAGE_STRIP = "1"
26