summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/ipc-modules/ipc-modules.inc
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-08-12 22:42:22 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:15 -0300
commitb4b27bd8c3cb00971634099197d88dfdfdcedf26 (patch)
treec989aeee92b2ccd758db7d4c3c8f4407e6636f98 /recipes-kernel/ipc-modules/ipc-modules.inc
parentbe1037c79f97b9b9651045b6176cde91a67f6560 (diff)
downloadmeta-freescale-b4b27bd8c3cb00971634099197d88dfdfdcedf26.tar.gz
ipc: Optimize the ipc recipes directories
* move ipc-ust recipes to recipes-extended folder * move ipc-modules to recipes-kernel folder Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Acked-by: Daiane Angolini <daiane.angolini@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/ipc-modules/ipc-modules.inc')
-rw-r--r--recipes-kernel/ipc-modules/ipc-modules.inc25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/ipc-modules/ipc-modules.inc b/recipes-kernel/ipc-modules/ipc-modules.inc
new file mode 100644
index 00000000..a496ab6d
--- /dev/null
+++ b/recipes-kernel/ipc-modules/ipc-modules.inc
@@ -0,0 +1,25 @@
1SUMMARY = "Linux IPC KERNEL MODULE "
2DESCRIPTION = "DSP boot application and ipc test application"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
5
6require recipes-extended/ipc-ust/ipc.inc
7
8inherit module qoriq_build_64bit_kernel
9
10S = "${WORKDIR}/git"
11
12do_configure[depends] += "virtual/kernel:do_shared_workdir"
13do_configure_prepend() {
14 sed -i 's,$(KERNEL_DIR)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/kernel/Makefile
15}
16
17do_compile_prepend () {
18 cd ${S}/kernel
19 case ${MACHINE} in
20 bsc9132qds|bsc9131rdb) SOC=B913x;;
21 b4860qds|b4420qds) SOC=B4860;;
22 esac
23}
24
25INHIBIT_PACKAGE_STRIP = "1"