summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/dtc/files/make_install.patch
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2018-06-15 16:08:28 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-06-26 14:16:13 -0300
commitddba499819c5834270d966877f2d15befbc4492e (patch)
treee8a63274140b0cdd2ef950bb0ee8c95efdf834a0 /recipes-kernel/dtc/files/make_install.patch
parentdff0ff3ebee7e27840fcfa8d447e864e6c6b16fc (diff)
downloadmeta-freescale-ddba499819c5834270d966877f2d15befbc4492e.tar.gz
dtc: Add recipe for version 1.4.5
We need dtc version 1.4.5 to build u-boot-imx 2017.03, current version 1.4.6 raise a lot of errors and can't build older U-Boot version. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/dtc/files/make_install.patch')
-rw-r--r--recipes-kernel/dtc/files/make_install.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/dtc/files/make_install.patch b/recipes-kernel/dtc/files/make_install.patch
new file mode 100644
index 00000000..ccf17b38
--- /dev/null
+++ b/recipes-kernel/dtc/files/make_install.patch
@@ -0,0 +1,17 @@
1Upstream-Status: Inappropriate [configuration]
2
3Index: git/Makefile
4===================================================================
5--- git.orig/Makefile
6+++ git/Makefile
7@@ -168,8 +168,8 @@ install-bin: all $(SCRIPTS)
8 install-lib: all
9 @$(VECHO) INSTALL-LIB
10 $(INSTALL) -d $(DESTDIR)$(LIBDIR)
11- $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
12- ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
13+ $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
14+ ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib))
15 ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT)
16 $(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR)
17