summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
diff options
context:
space:
mode:
authorCristian Stoica <cristian.stoica@nxp.com>2016-01-25 11:19:43 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commitb8e3085e4e9608b301121c7065c84a3e51b94c74 (patch)
tree27dd6761bb8a8b9a3ce311bab1155a15badaec5e /recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
parent578ab5d071729c9677d928467a2b48bcb0017139 (diff)
downloadmeta-freescale-b8e3085e4e9608b301121c7065c84a3e51b94c74.tar.gz
cryptodev-qoriq: upgrade to 1.8 plus fsl patches
upstream commit: 87b56e04b24c6d4be145483477eff7d3153290e9 Also: - move all fsl patches on top of cryptodev-1.8 - add CIOCHASH ioctl - fix incorrect tests initializations - modify yocto patches to match updated Makefiles Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
Diffstat (limited to 'recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch')
-rw-r--r--recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch b/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
new file mode 100644
index 00000000..1e7f5843
--- /dev/null
+++ b/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
@@ -0,0 +1,50 @@
1From 03257bf2aff37b78496ccc1b58a87e7baaea042a Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Mon, 22 Feb 2016 12:17:52 +0200
4Subject: [PATCH 2/2] Add the compile and install rules for cryptodev tests
5
6(original patch Signed-off-by: Yu Zongchun <b40527@freescale.com>)
7Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
8
9Upstream-Status: Inappropriate [ OE specific ]
10---
11 Makefile | 6 ++++++
12 tests/Makefile | 4 ++--
13 2 files changed, 8 insertions(+), 2 deletions(-)
14
15diff --git a/Makefile b/Makefile
16index 06202bd..a598b12 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -42,6 +42,12 @@ clean:
20 check:
21 CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
22
23+testprogs:
24+ KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests all
25+
26+install_tests:
27+ $(MAKE) -C tests install
28+
29 CPOPTS =
30 ifneq ($(SHOW_TYPES),)
31 CPOPTS += --show-types
32diff --git a/tests/Makefile b/tests/Makefile
33index 5e3111d..cda971c 100644
34--- a/tests/Makefile
35+++ b/tests/Makefile
36@@ -35,9 +35,9 @@ check: $(hostprogs)
37 ./cipher-aead
38
39 install:
40- install -d $(DESTDIR)/$(bindir)
41+ install -d $(DESTDIR)/$(bindir)/tests_cryptodev
42 for prog in $(hostprogs); do \
43- install -m 755 $$prog $(DESTDIR)/$(bindir); \
44+ install -m 755 $$prog $(DESTDIR)/$(bindir)/tests_cryptodev/; \
45 done
46
47 clean:
48--
492.7.0
50