summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
diff options
context:
space:
mode:
authorCristian Stoica <cristian.stoica@nxp.com>2016-01-25 11:19:43 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commitb8e3085e4e9608b301121c7065c84a3e51b94c74 (patch)
tree27dd6761bb8a8b9a3ce311bab1155a15badaec5e /recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
parent578ab5d071729c9677d928467a2b48bcb0017139 (diff)
downloadmeta-freescale-b8e3085e4e9608b301121c7065c84a3e51b94c74.tar.gz
cryptodev-qoriq: upgrade to 1.8 plus fsl patches
upstream commit: 87b56e04b24c6d4be145483477eff7d3153290e9 Also: - move all fsl patches on top of cryptodev-1.8 - add CIOCHASH ioctl - fix incorrect tests initializations - modify yocto patches to match updated Makefiles Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
Diffstat (limited to 'recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
new file mode 100644
index 00000000..f7d0b61b
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.8.bb
@@ -0,0 +1,26 @@
1require cryptodev-qoriq_${PV}.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
5DEPENDS = "openssl"
6
7PROVIDES = "cryptodev-tests"
8
9EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" DESTDIR="${D}"'
10
11SRC_URI_append = " \
12file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
13"
14
15do_compile() {
16 oe_runmake testprogs
17}
18
19do_install() {
20 oe_runmake install_tests
21}
22
23FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
24FILES_${PN} = "${bindir}/tests_cryptodev/*"
25
26COMPATIBLE_MACHINE = "(qoriq)"