summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/ceetm/ceetm_git.bb
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-01-09 14:43:14 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:23 -0300
commitf4290a9ed0c522e5bbadd81c3f5018681eb81430 (patch)
tree9a71b087a639d62f672cf17fac18f18a71a7ae17 /recipes-kernel/ceetm/ceetm_git.bb
parentc9faec51bbaebd2bfabf19d9de0c00c5adc6b99d (diff)
downloadmeta-freescale-f4290a9ed0c522e5bbadd81c3f5018681eb81430.tar.gz
kernel-module-ceetm: rename back to ceetm
ceetm ships not only ceetm.ko, but also q_ceetm.so. Rename back to ceetm As the recipe inherits module.bbclass, kernel-module-ceetm will be created to package ceetm.ko if it is installed into /lib/modules/. Signed-off-by: Ting Liu <ting.liu@nxp.com>> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/ceetm/ceetm_git.bb')
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
new file mode 100644
index 00000000..7009b2db
--- /dev/null
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "CEETM TC QDISC"
2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
4
5inherit module qoriq_build_64bit_kernel
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1"
8SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008"
9
10S = "${WORKDIR}/git"
11
12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
13export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
14
15do_configure[depends] += "virtual/kernel:do_shared_workdir"
16do_configure_prepend () {
17 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/ceetm_module/Makefile
18}
19
20do_install(){
21 mkdir -p ${D}/usr/driver/ceetm
22 mkdir -p ${D}/${libdir}/tc
23 cp ${S}/bin/ceetm.ko ${D}/usr/driver/ceetm
24 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/.
25}
26
27FILES_${PN} += "/usr/driver/ceetm ${libdir}/tc"
28INHIBIT_PACKAGE_STRIP = "1"
29
30COMPATIBLE_MACHINE = "(e6500-64b|t1040|t1042)"