summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/ceetm/ceetm_git.bb
diff options
context:
space:
mode:
authorCamelia Groza <camelia.groza@freescale.com>2016-03-15 15:04:04 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commit85005417707a043c8b9d928f82a9b171f8b7e8eb (patch)
tree05cdf84445eade4d1db390595f53f5059fcd3532 /recipes-kernel/ceetm/ceetm_git.bb
parentea5b2aefce168f5c69b8c49fef0e30cee9aa1825 (diff)
downloadmeta-freescale-85005417707a043c8b9d928f82a9b171f8b7e8eb.tar.gz
ceetm: update to a237e09
* kernel module was seperated now, no need to build/install * update the compatible machine list Changelog: a237e09 ceetm: qcount and qweight aren't mandatory; update the help message 09fd87e ceetm: change the qweight for wbfs classes at runtime 09d6bc7 ceetm: remove the ceetm kernel module fd9c4b3 ceetm: update class statistics 92c37a4 ceetm: edit the help message d155fd6 ceetm: configure the cr and er of prio classes 610e157 ceetm: separate print_opt into two calls 3a35a3c ceetm: configure the wbfs weight 3b2fdd0 ceetm: show wbfs classes 8b42626 ceetm: add the wbfs qdisc e9deb04 ceetm: merge the qdisc and class types; allow rates equal to 0 e45fc61 Configure the channels in the root classes 0eb7c9b Print a prio class 270c21b ceetm: configure the prio qdisc f272dbe ceetm: configure the root qdisc and the underlying classes fa07c93 ceetm: update the qdisc's help messages 1adfe00 ceetm: obtain the port's subportal dynamically Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-kernel/ceetm/ceetm_git.bb')
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb13
1 files changed, 3 insertions, 10 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
index 228daddb..e6687a4d 100644
--- a/recipes-kernel/ceetm/ceetm_git.bb
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -2,25 +2,18 @@ DESCRIPTION = "CEETM TC QDISC"
2LICENSE = "GPLv2 & BSD" 2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" 3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
4 4
5inherit module qoriq_build_64bit_kernel 5SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;branch=sdk-v2.0.x"
6 6SRCREV = "a237e094c3316a55727b855d15480e664545316a"
7SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;branch=sdk-v1.9.x"
8SRCREV = "2c79d0b3465368a19bb2b4ccd680ddd297ebe377"
9 7
10S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
11 9
12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" 10EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
13export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
14 11
15do_configure[depends] += "virtual/kernel:do_shared_workdir"
16do_install(){ 12do_install(){
17 install -d ${D}/lib/modules/${KERNEL_VERSION}/extra
18 mkdir -p ${D}/${libdir}/tc 13 mkdir -p ${D}/${libdir}/tc
19 install -m 644 ${S}/bin/ceetm.ko ${D}/lib/modules/${KERNEL_VERSION}/extra/
20 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/ 14 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/
21} 15}
22 16
23FILES_${PN} += "${libdir}/tc" 17FILES_${PN} += "${libdir}/tc"
24INHIBIT_PACKAGE_STRIP = "1" 18INHIBIT_PACKAGE_STRIP = "1"
25 19COMPATIBLE_MACHINE = "(b4|t1|t2|t4|ls1043a)"
26COMPATIBLE_MACHINE = "(e6500-64b|t1040|t1042)"