summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/ceetm/ceetm_git.bb
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-08-28 18:36:51 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:16 -0300
commit2cb9b8e60acc4000b462952d8127718a5056c595 (patch)
treedae14732e5ae6a0bf030e9ef3225768dacff379d /recipes-kernel/ceetm/ceetm_git.bb
parent6a6b6f198bec8e97d03983a666703757b21a197d (diff)
downloadmeta-freescale-2cb9b8e60acc4000b462952d8127718a5056c595.tar.gz
rename ceetm to kernel-module-ceetm and move bb to kernel-modules subdir
* rename ceetm to kernel-module-ceetm * move bb file to the common kernel-modules subdirectory Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/ceetm/ceetm_git.bb')
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
deleted file mode 100644
index 5d89531f..00000000
--- a/recipes-kernel/ceetm/ceetm_git.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DESCRIPTION = "CEETM TC QDISC"
2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
4
5inherit module qoriq_build_64bit_kernel
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1"
8SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008"
9
10S = "${WORKDIR}/git"
11
12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
13export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
14
15do_configure[depends] += "virtual/kernel:do_shared_workdir"
16do_configure_prepend () {
17 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/ceetm_module/Makefile
18}
19
20do_install(){
21 mkdir -p ${D}/usr/driver/ceetm
22 mkdir -p ${D}/${libdir}/tc
23 cp ${S}/bin/ceetm.ko ${D}/usr/driver/ceetm
24 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/.
25}
26
27FILES_${PN} += "/usr/driver/ceetm ${libdir}/tc"
28INHIBIT_PACKAGE_STRIP = "1"
29
30COMPATIBLE_MACHINE = "(e6500-64b|t1040rdb|t1040rdb-64b|t1042rdb|t1042rdb-64b)"