diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2018-10-29 17:10:49 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2018-10-30 15:20:40 -0500 |
commit | 9fd2288eb22ec5fb731b25c187be35b2d1e2a47c (patch) | |
tree | 53fe3e9c939c65f5ce7c5aba824a9ed0075e4043 /recipes-graphics | |
parent | 15b562efdaa7baed7ae35c64c633a0fafe794723 (diff) | |
download | meta-freescale-9fd2288eb22ec5fb731b25c187be35b2d1e2a47c.tar.gz |
weston: Fix open function build break in g2d-renderer
| from ../git/libweston/g2d-renderer.c:40:
| In function 'open',
| inlined from 'g2d_renderer_create' at ../git/libweston/g2d-renderer.c:1629:2:
| /home/r60874/upstream/fsl-xwayland/tmp/work/cortexa9t2hf-neon-mx6qdl-fsl-linux-gnueabi/weston/4.0.0.imx-r0/recipe- sysroot/usr/include/bits/fcntl2.h:50:4: error: call to '__open_missing_mode' declared with attribute error: open wit h O_CREAT or O_TMPFILE in second argument needs 3 arguments
| __open_missing_mode ();
| ^~~~~~~~~~~~~~~~~~~~~~
| Makefile:5266: recipe for target 'libweston/g2d_renderer_la-g2d-renderer.lo' failed
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/wayland/weston/0001-g2d-renderer-Fix-open-function-build-break.patch | 45 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_4.0.0.imx.bb | 1 |
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston/0001-g2d-renderer-Fix-open-function-build-break.patch b/recipes-graphics/wayland/weston/0001-g2d-renderer-Fix-open-function-build-break.patch new file mode 100644 index 00000000..38e78aa2 --- /dev/null +++ b/recipes-graphics/wayland/weston/0001-g2d-renderer-Fix-open-function-build-break.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From 7857e5aa2459b2746e062ae59ae0240c4af7af5d Mon Sep 17 00:00:00 2001 | ||
2 | From: Tom Hochstein <tom.hochstein@nxp.com> | ||
3 | Date: Mon, 29 Oct 2018 21:40:32 +0000 | ||
4 | Subject: [PATCH] g2d-renderer: Fix open function build break | ||
5 | |||
6 | | from ../git/libweston/g2d-renderer.c:40: | ||
7 | | In function 'open', | ||
8 | | inlined from 'g2d_renderer_create' at ../git/libweston/g2d-renderer.c:1629:2: | ||
9 | | /home/r60874/upstream/fsl-xwayland/tmp/work/cortexa9t2hf-neon-mx6qdl-fsl-linux-gnueabi/weston/4.0.0.imx-r0/recipe- sysroot/usr/include/bits/fcntl2.h:50:4: error: call to '__open_missing_mode' declared with attribute error: open wit h O_CREAT or O_TMPFILE in second argument needs 3 arguments | ||
10 | | __open_missing_mode (); | ||
11 | | ^~~~~~~~~~~~~~~~~~~~~~ | ||
12 | | Makefile:5266: recipe for target 'libweston/g2d_renderer_la-g2d-renderer.lo' failed | ||
13 | |||
14 | Upstream-Status: Inappropriate [i.MX-specific] | ||
15 | |||
16 | Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> | ||
17 | --- | ||
18 | libweston/g2d-renderer.c | 4 ++-- | ||
19 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
20 | |||
21 | diff --git a/libweston/g2d-renderer.c b/libweston/g2d-renderer.c | ||
22 | index cc82711..0675350 100644 | ||
23 | --- a/libweston/g2d-renderer.c | ||
24 | +++ b/libweston/g2d-renderer.c | ||
25 | @@ -1626,7 +1626,7 @@ g2d_renderer_create(struct weston_compositor *ec) | ||
26 | path = malloc(strlen(dir) + 40); | ||
27 | strcpy(path, dir); | ||
28 | strcat(path, "/use-g2d-renderer"); | ||
29 | - close(open(path, O_CREAT | O_RDWR)); | ||
30 | + close(open(path, O_CREAT | O_RDWR, 0600)); | ||
31 | free(path); | ||
32 | |||
33 | return 0; | ||
34 | @@ -1804,7 +1804,7 @@ fb_frame_buffer_open(struct g2d_output_state *output, const char *fb_dev, | ||
35 | struct fb_screeninfo *screen_info) | ||
36 | { | ||
37 | /* Open the frame buffer device. */ | ||
38 | - screen_info->fb_fd = open(fb_dev, O_RDWR | O_CLOEXEC); | ||
39 | + screen_info->fb_fd = open(fb_dev, O_RDWR | O_CLOEXEC, 0600); | ||
40 | if (screen_info->fb_fd < 0) { | ||
41 | weston_log("Failed to open frame buffer device%s \n", fb_dev); | ||
42 | return -1; | ||
43 | -- | ||
44 | 2.7.4 | ||
45 | |||
diff --git a/recipes-graphics/wayland/weston_4.0.0.imx.bb b/recipes-graphics/wayland/weston_4.0.0.imx.bb index 40f8cc61..47104633 100644 --- a/recipes-graphics/wayland/weston_4.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_4.0.0.imx.bb | |||
@@ -15,6 +15,7 @@ SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=http | |||
15 | file://0001-make-error-portable.patch \ | 15 | file://0001-make-error-portable.patch \ |
16 | file://xwayland.weston-start \ | 16 | file://xwayland.weston-start \ |
17 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ | 17 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ |
18 | file://0001-g2d-renderer-Fix-open-function-build-break.patch \ | ||
18 | " | 19 | " |
19 | SRCREV = "866072b52751e5023651dd9322baa513e1f74fe6" | 20 | SRCREV = "866072b52751e5023651dd9322baa513e1f74fe6" |
20 | S = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/git" |