diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-12 21:00:25 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-12 21:00:25 -0700 |
commit | 0dad0e1e9d075a957cf334e68ec5f09afeb3c2bd (patch) | |
tree | 0209a07b77eabdf3418e3bd4279bde20c212e585 /recipes-graphics | |
parent | 8324178f01ddf4b2da9e0b7bcbc4abde0b8c6aa8 (diff) | |
download | meta-freescale-0dad0e1e9d075a957cf334e68ec5f09afeb3c2bd.tar.gz |
weston: Fix build with clang-15
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch | 34 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_10.0.0.imx.bb | 4 |
2 files changed, 37 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch b/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch new file mode 100644 index 00000000..b9cb31fb --- /dev/null +++ b/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 4afe9b2f9ef24ce0c9bf1cd41f94ca45afa4f445 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 12 Sep 2022 20:58:14 -0700 | ||
4 | Subject: [PATCH] g2d-renderer.c: Include sys/stat.h | ||
5 | |||
6 | This is needed for getting stat() prototype, its flagged with clang-15 | ||
7 | as error. | ||
8 | |||
9 | | ../git/libweston/renderer-g2d/g2d-renderer.c:2057:6: error: call to undeclared function 'stat'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration] | ||
10 | | if (stat(gr->drm_device, &dev_stat) != 0) { | ||
11 | | ^ | ||
12 | | 1 error generated. | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
17 | libweston/renderer-g2d/g2d-renderer.c | 1 + | ||
18 | 1 file changed, 1 insertion(+) | ||
19 | |||
20 | diff --git a/libweston/renderer-g2d/g2d-renderer.c b/libweston/renderer-g2d/g2d-renderer.c | ||
21 | index f59fc4ee..36a458fc 100644 | ||
22 | --- a/libweston/renderer-g2d/g2d-renderer.c | ||
23 | +++ b/libweston/renderer-g2d/g2d-renderer.c | ||
24 | @@ -41,6 +41,7 @@ | ||
25 | #include <drm_fourcc.h> | ||
26 | #include <poll.h> | ||
27 | #include <errno.h> | ||
28 | +#include <sys/stat.h> /* stat() */ | ||
29 | |||
30 | #include <libweston/libweston.h> | ||
31 | #include "g2d-renderer.h" | ||
32 | -- | ||
33 | 2.37.3 | ||
34 | |||
diff --git a/recipes-graphics/wayland/weston_10.0.0.imx.bb b/recipes-graphics/wayland/weston_10.0.0.imx.bb index 8fce4472..a9f6ec13 100644 --- a/recipes-graphics/wayland/weston_10.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_10.0.0.imx.bb | |||
@@ -160,7 +160,9 @@ DEFAULT_PREFERENCE = "-1" | |||
160 | 160 | ||
161 | SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz" | 161 | SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz" |
162 | SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} " | 162 | SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} " |
163 | SRC_URI += "file://0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch" | 163 | SRC_URI += "file://0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch \ |
164 | file://0001-g2d-renderer.c-Include-sys-stat.h.patch \ | ||
165 | " | ||
164 | SRCBRANCH = "weston-imx-10.0" | 166 | SRCBRANCH = "weston-imx-10.0" |
165 | SRCREV = "c8c6e3106b03441db1037afa995f95fcb2f9f17d" | 167 | SRCREV = "c8c6e3106b03441db1037afa995f95fcb2f9f17d" |
166 | 168 | ||