diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-20 20:50:36 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:13 -0300 |
commit | 4420431e43c6affcb02fad33532d42f1e1d06173 (patch) | |
tree | b78a27d4fd993536c6ab1e23840a63834de95ff6 /recipes-graphics | |
parent | 614ee7f1c907aeabe37f500431a3491f7132a1bc (diff) | |
download | meta-freescale-4420431e43c6affcb02fad33532d42f1e1d06173.tar.gz |
mesa: Fix override of x11 GLX support for i.MX6
The replacement of --enable-glx-tls for --enable-glx was not working
due the way the variables are expanded. To fix the issue an annonymous
function has been added to mangle it just before its use.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 12 |
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 5030e7a3..f8cf1bce 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -18,6 +18,17 @@ USE_VIV_LIBGL_mx6q = "yes" | |||
18 | USE_VIV_LIBGL_mx6dl = "yes" | 18 | USE_VIV_LIBGL_mx6dl = "yes" |
19 | USE_VIV_LIBGL_mx6sx = "yes" | 19 | USE_VIV_LIBGL_mx6sx = "yes" |
20 | 20 | ||
21 | # FIXME: mesa should support 'x11-no-tls' option | ||
22 | python () { | ||
23 | overrides = d.getVar("OVERRIDES", True).split(":") | ||
24 | if "mx6" not in overrides: | ||
25 | return | ||
26 | |||
27 | extra_oeconf = d.getVar("EXTRA_OECONF", True) | ||
28 | extra_oeconf = extra_oeconf.replace("--enable-glx-tls", "--enable-glx") | ||
29 | d.setVar("EXTRA_OECONF", extra_oeconf) | ||
30 | } | ||
31 | |||
21 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary | 32 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary |
22 | do_install_append_mx6 () { | 33 | do_install_append_mx6 () { |
23 | if [ "${USE_VIV_LIBGL}" = "yes" ]; then | 34 | if [ "${USE_VIV_LIBGL}" = "yes" ]; then |
@@ -26,4 +37,3 @@ do_install_append_mx6 () { | |||
26 | ${D}${includedir}/GL/glext.h | 37 | ${D}${includedir}/GL/glext.h |
27 | fi | 38 | fi |
28 | } | 39 | } |
29 | EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}" | ||