summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-30 16:53:55 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:14 -0300
commit03c461be46850debdeb696620990449634435144 (patch)
tree95ae9a1db71b0b938b1b2f1f03a38dea5ec7ae8f /recipes-graphics
parentc69115a0373bb0495d0e3bdbc161466b121ed361 (diff)
downloadmeta-freescale-03c461be46850debdeb696620990449634435144.tar.gz
mesa-demos: Support for mx6 without GPUs
Fix to support future mx6 i.MX 6UltraLite which does not have a GPU. This SoC will use mesa so mesa changes before should be more SoC specific to allow future mx6 SoC without GPU to use mesa. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index 65f3d53b..c8d1667a 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -9,4 +9,11 @@ SRC_URI_append_mx6dl = " ${MESA-DEMO-PATCH}"
9SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}" 9SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}"
10SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}" 10SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}"
11 11
12PACKAGECONFIG_remove_mx6sl = "gles1 gles2" 12REMOVE_GLU = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
13 bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}"
14
15# only remove GLU on mx6 thave have a GPU
16PACKAGECONFIG_remove_mx6q = "${REMOVE_GLU}"
17PACKAGECONFIG_remove_mx6dl = "${REMOVE_GLU}"
18PACKAGECONFIG_remove_mx6sx = "${REMOVE_GLU}"
19PACKAGECONFIG_remove_mx6sl = "gles1 gles2 ${REMOVE_GLU}"