diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-10-29 09:22:55 -0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:21 -0300 |
commit | ac2d289ab6ba92ca10b6926b285656820b6b826c (patch) | |
tree | 3b503766337552948f263e3e248093bd7e85e32d /recipes-graphics | |
parent | b3595d343332a8a564bb29cfa694be45fed24083 (diff) | |
download | meta-freescale-ac2d289ab6ba92ca10b6926b285656820b6b826c.tar.gz |
Remove DirectFB support for i.MX6
The DirectFB project is dead upstream for a while and the backend is
deprecated so it is better to drop it and avoid new users to depend on
it and instead to focus in the current technologies for new projects.
This commit removes everything related to the DirectFB support so if
someone wish to revert it locally it can be easily done.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Acked-by: Daiane Angolini <daiane.angolini@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/cairo/cairo_%.bbappend | 5 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb.inc | 79 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb/Check-input-NULL-pointer.patch | 42 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb/bashism.patch | 18 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb/configurefix.patch | 60 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb/fixsepbuild.patch | 19 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb/fusion.patch | 36 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb_%.bbappend | 3 | ||||
-rw-r--r-- | recipes-graphics/directfb/directfb_1.7.4.bb | 24 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc | 29 |
10 files changed, 7 insertions, 308 deletions
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend index ab1c37a5..66e019aa 100644 --- a/recipes-graphics/cairo/cairo_%.bbappend +++ b/recipes-graphics/cairo/cairo_%.bbappend | |||
@@ -1,10 +1,7 @@ | |||
1 | CFLAGS_append_mx6 = " -DLINUX \ | 1 | CFLAGS_append_mx6 = " -DLINUX \ |
2 | ${@base_contains('DISTRO_FEATURES', 'x11', '', \ | 2 | ${@base_contains('DISTRO_FEATURES', 'x11', '', \ |
3 | base_contains('DISTRO_FEATURES', 'wayland', \ | 3 | base_contains('DISTRO_FEATURES', 'wayland', \ |
4 | '-DEGL_API_FB -DEGL_API_WL', \ | 4 | '-DEGL_API_FB -DEGL_API_WL', '-DEGL_API_FB', d), d)}" |
5 | base_contains('DISTRO_FEATURES', 'directfb', \ | ||
6 | '-DEGL_API_DFB', '-DEGL_API_FB', d),d),d)}" | ||
7 | |||
8 | 5 | ||
9 | PACKAGECONFIG_append_mx6q = " egl glesv2" | 6 | PACKAGECONFIG_append_mx6q = " egl glesv2" |
10 | PACKAGECONFIG_append_mx6dl = " egl glesv2" | 7 | PACKAGECONFIG_append_mx6dl = " egl glesv2" |
diff --git a/recipes-graphics/directfb/directfb.inc b/recipes-graphics/directfb/directfb.inc deleted file mode 100644 index 9e909422..00000000 --- a/recipes-graphics/directfb/directfb.inc +++ /dev/null | |||
@@ -1,79 +0,0 @@ | |||
1 | SUMMARY = "Graphics abstraction library for the Linux Framebuffer Device" | ||
2 | DESCRIPTION = "DirectFB is a thin library that provides developers \ | ||
3 | with hardware graphics acceleration, input device handling and \ | ||
4 | abstraction, an integrated windowing system with support for \ | ||
5 | translucent windows and multiple display layers on top of the \ | ||
6 | Linux framebuffer device." | ||
7 | SECTION = "libs" | ||
8 | LICENSE = "LGPLv2.1" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589" | ||
10 | |||
11 | HOMEPAGE = "http://directfb.org" | ||
12 | DEPENDS = "jpeg libpng freetype zlib tslib sysfsutils" | ||
13 | |||
14 | SRC_URI = "http://www.directfb.org/downloads/Core/DirectFB-1.7/DirectFB-${PV}.tar.gz \ | ||
15 | file://configurefix.patch \ | ||
16 | file://fusion.patch \ | ||
17 | file://bashism.patch \ | ||
18 | " | ||
19 | |||
20 | S = "${WORKDIR}/DirectFB-${PV}" | ||
21 | |||
22 | LDFLAGS_append =" -lts -lm" | ||
23 | |||
24 | BINCONFIG = "${bindir}/directfb-config" | ||
25 | |||
26 | inherit autotools binconfig-disabled pkgconfig | ||
27 | |||
28 | PACKAGECONFIG ??= "" | ||
29 | PACKAGECONFIG[jpeg2000] = "--enable-jpeg2000,--disable-jpeg2000,jasper" | ||
30 | PACKAGECONFIG[drmkms] = "--enable-drmkms,--disable-drmkms,libdrm" | ||
31 | PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff" | ||
32 | PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp" | ||
33 | |||
34 | EXTRA_OECONF = "\ | ||
35 | --with-gfxdrivers=none \ | ||
36 | --enable-freetype=yes \ | ||
37 | --enable-zlib \ | ||
38 | --disable-imlib2 \ | ||
39 | --disable-mesa \ | ||
40 | --disable-sdl \ | ||
41 | --disable-vnc \ | ||
42 | --disable-x11 \ | ||
43 | " | ||
44 | |||
45 | #Once -fno-omit-frame-pointer option of gcc is added into TARGET_CLFAGS as default | ||
46 | #this will cause directfb build failure on x86 arch, so filter out it. | ||
47 | TARGET_CFLAGS_remove_x86 = "-fno-omit-frame-pointer" | ||
48 | |||
49 | #PACKAGES_DYNAMIC += "^directfb-inputdrivers-.*" | ||
50 | # | ||
51 | #python populate_packages_prepend () { | ||
52 | # inputdrivers_libdir = d.expand('${libdir}/directfb-${RV}/inputdrivers') | ||
53 | # do_split_packages(d, inputdrivers_libdir, '*.so$', 'directfb-inputdrivers-%s', 'Directfb plugin for %s') | ||
54 | #} | ||
55 | |||
56 | # NOTE: monolithic packaging for now, should improve that eventually | ||
57 | |||
58 | |||
59 | |||
60 | FILES_${PN}-dbg += "\ | ||
61 | ${libdir}/directfb-${RV}/*/*/.debug/*.so \ | ||
62 | ${libdir}/directfb-${RV}/*/.debug/*.so \ | ||
63 | " | ||
64 | |||
65 | FILES_${PN}-dev += "\ | ||
66 | ${bindir}/directfb-config \ | ||
67 | ${libdir}/directfb-${RV}/systems/*.la \ | ||
68 | ${libdir}/directfb-${RV}/inputdrivers/*.la \ | ||
69 | ${libdir}/directfb-${RV}/interfaces/*/*.la \ | ||
70 | ${libdir}/directfb-${RV}/wm/*.la \ | ||
71 | " | ||
72 | |||
73 | FILES_${PN} += "\ | ||
74 | ${libdir}/directfb-${RV}/systems/*.so \ | ||
75 | ${libdir}/directfb-${RV}/inputdrivers/*.so \ | ||
76 | ${libdir}/directfb-${RV}/interfaces/*/*.so \ | ||
77 | ${libdir}/directfb-${RV}/wm/*.so \ | ||
78 | ${datadir}/directfb-${PV} \ | ||
79 | " | ||
diff --git a/recipes-graphics/directfb/directfb/Check-input-NULL-pointer.patch b/recipes-graphics/directfb/directfb/Check-input-NULL-pointer.patch deleted file mode 100644 index 1d541722..00000000 --- a/recipes-graphics/directfb/directfb/Check-input-NULL-pointer.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | From 0c1e3d1d54b7f2e637b0984ea10aef1de278ff87 Mon Sep 17 00:00:00 2001 | ||
2 | From: "yong.gan" <yong.gan@freescale.com> | ||
3 | Date: Fri, 23 May 2014 14:15:09 +0800 | ||
4 | Subject: [PATCH] Check input NULL pointer | ||
5 | |||
6 | Fix the segmentation fault in multi-instance test. | ||
7 | |||
8 | Upstream Status: Pending | ||
9 | --- | ||
10 | inputdrivers/linux_input/linux_input.c | 2 +- | ||
11 | src/core/input.c | 2 ++ | ||
12 | 2 files changed, 3 insertions(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/inputdrivers/linux_input/linux_input.c b/inputdrivers/linux_input/linux_input.c | ||
15 | index e275762..35cfbdd 100644 | ||
16 | --- a/inputdrivers/linux_input/linux_input.c | ||
17 | +++ b/inputdrivers/linux_input/linux_input.c | ||
18 | @@ -1979,7 +1979,7 @@ driver_get_keymap_entry( CoreInputDevice *device, | ||
19 | unsigned short value; | ||
20 | DFBInputDeviceKeyIdentifier identifier; | ||
21 | |||
22 | - if (data->vt_fd < 0) | ||
23 | + if (data == NULL || data->vt_fd < 0) | ||
24 | return DFB_UNSUPPORTED; | ||
25 | |||
26 | /* fetch the base level */ | ||
27 | diff --git a/src/core/input.c b/src/core/input.c | ||
28 | index d77bc9f..ee23909 100644 | ||
29 | --- a/src/core/input.c | ||
30 | +++ b/src/core/input.c | ||
31 | @@ -723,6 +723,8 @@ dfb_input_core_suspend( DFBInputCore *data ) | ||
32 | driver->info.name ); | ||
33 | } | ||
34 | } | ||
35 | + if(data == NULL) | ||
36 | + return DFB_FAILURE; | ||
37 | |||
38 | direct_list_foreach (device, data->devices) { | ||
39 | InputDeviceShared *devshared; | ||
40 | -- | ||
41 | 1.9.1 | ||
42 | |||
diff --git a/recipes-graphics/directfb/directfb/bashism.patch b/recipes-graphics/directfb/directfb/bashism.patch deleted file mode 100644 index 2ef4e938..00000000 --- a/recipes-graphics/directfb/directfb/bashism.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | ${x//y/} is a bash syntax. Replace with something dash compatible | ||
2 | |||
3 | RP 2015/5/3 | ||
4 | Upstream-Status: Pending | ||
5 | |||
6 | Index: DirectFB-1.7.7/configure.in | ||
7 | =================================================================== | ||
8 | --- DirectFB-1.7.7.orig/configure.in | ||
9 | +++ DirectFB-1.7.7/configure.in | ||
10 | @@ -2696,7 +2696,7 @@ AM_CONDITIONAL(BUILD_TOOLS, test "$with_ | ||
11 | AM_CONDITIONAL(CROSS_COMPILING, test "$cross_compiling" = "yes") | ||
12 | |||
13 | CFLAGS="$CFLAGS $DFB_INTERNAL_CFLAGS" | ||
14 | -CXXFLAGS="$CXXFLAGS ${CFLAGS//-Werror-implicit-function-declaration/}" | ||
15 | +CXXFLAGS="$CXXFLAGS $(printf '%s\n' "$CFLAGS" | sed 's/-Werror-implicit-function-declaration//g')" | ||
16 | DFB_LDFLAGS="$LDFLAGS $ZLIB_LIBS" | ||
17 | |||
18 | CFLAGS="$CFLAGS $CFLAGS_STD" | ||
diff --git a/recipes-graphics/directfb/directfb/configurefix.patch b/recipes-graphics/directfb/directfb/configurefix.patch deleted file mode 100644 index dd8c0190..00000000 --- a/recipes-graphics/directfb/directfb/configurefix.patch +++ /dev/null | |||
@@ -1,60 +0,0 @@ | |||
1 | Libtool needs these set correctly else we end up with pointless rpaths | ||
2 | such as the QA warnings: | ||
3 | |||
4 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfblayer contains probably-redundant RPATH /usr/libWARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbmaster contains probably-redundant RPATH /usr/libWARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/mkdgifft contains probably-redundant RPATH /usr/libWARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbdump contains probably-redundant RPATH /usr/libWARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbinput contains probably-redundant RPATH /usr/libWARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbfx contains probably-redundant RPATH /usr/libWARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbscreen contains probably-redundant RPATH /usr/libWARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/mkdgiff contains probably-redundant RPATH /usr/libWARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbinspector contains probably-redundant RPATH /usr/lib | ||
5 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/mkdfiff contains probably-redundant RPATH /usr/lib | ||
6 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbinfo contains probably-redundant RPATH /usr/lib | ||
7 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbpenmount contains probably-redundant RPATH /usr/lib | ||
8 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/bin/dfbg contains probably-redundant RPATH /usr/lib | ||
9 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/libfusion-1.4.so.6 contains probably-redundant RPATH /usr/lib | ||
10 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/libdirectfb-1.4.so.6.0.9 contains probably-redundant RPATH /usr/lib | ||
11 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/libdirectfb-1.4.so.6 contains probably-redundant RPATH /usr/lib | ||
12 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/libfusion-1.4.so.6.0.9 contains probably-redundant RPATH /usr/lib | ||
13 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/systems/libdirectfb_fbdev.so contains probably-redundant RPATH /usr/lib | ||
14 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/systems/libdirectfb_devmem.so contains probably-redundant RPATH /usr/lib | ||
15 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/systems/libdirectfb_dummy.so contains probably-redundant RPATH /usr/lib | ||
16 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so contains probably-redundant RPATH /usr/lib | ||
17 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_gif.so contains probably-redundant RPATH /usr/lib | ||
18 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/ICoreResourceManager/libicoreresourcemanager_test.so contains probably-redundant RPATH /usr/lib | ||
19 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so contains probably-redundant RPATH /usr/lib | ||
20 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so contains probably-redundant RPATH /usr/lib | ||
21 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dfiff.so contains probably-redundant RPATH /usr/lib | ||
22 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so contains probably-redundant RPATH /usr/lib | ||
23 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/IDirectFBFont/libidirectfbfont_ft2.so contains probably-redundant RPATH /usr/lib | ||
24 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/interfaces/IDirectFBFont/libidirectfbfont_dgiff.so contains probably-redundant RPATH /usr/lib | ||
25 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/wm/libdirectfbwm_default.so contains probably-redundant RPATH /usr/lib | ||
26 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_zytronic.so contains probably-redundant RPATH /usr/lib | ||
27 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_penmount.so contains probably-redundant RPATH /usr/lib | ||
28 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_linux_input.so contains probably-redundant RPATH /usr/lib | ||
29 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_serialmouse.so contains probably-redundant RPATH /usr/lib | ||
30 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_mutouch.so contains probably-redundant RPATH /usr/lib | ||
31 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_tslib.so contains probably-redundant RPATH /usr/lib | ||
32 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_joystick.so contains probably-redundant RPATH /usr/lib | ||
33 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_sonypi.so contains probably-redundant RPATH /usr/lib | ||
34 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_lirc.so contains probably-redundant RPATH /usr/lib | ||
35 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_wm97xx_ts.so contains probably-redundant RPATH /usr/lib | ||
36 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_ps2mouse.so contains probably-redundant RPATH /usr/lib | ||
37 | WARNING: QA Issue: directfb: /work/i586-poky-linux/directfb-1.4.15-r1/packages-split/directfb/usr/lib/directfb-1.4-6/inputdrivers/libdirectfb_keyboard.so contains probably-redundant RPATH /usr/lib | ||
38 | |||
39 | Upstream-Status: Pending | ||
40 | |||
41 | RP 2012/03/16 | ||
42 | |||
43 | Index: DirectFB-1.4.15/configure.in | ||
44 | =================================================================== | ||
45 | --- DirectFB-1.4.15.orig/configure.in 2012-03-16 13:32:23.692402879 +0000 | ||
46 | +++ DirectFB-1.4.15/configure.in 2012-03-16 13:33:22.312400960 +0000 | ||
47 | @@ -97,13 +97,6 @@ | ||
48 | AC_CHECK_SIZEOF(long long) | ||
49 | AC_CHECK_FUNCS(fork) | ||
50 | |||
51 | - | ||
52 | -## Work around libstuhl during cross build... | ||
53 | -if test "$host" != "$build"; then | ||
54 | - sys_lib_dlsearch_path_spec="" | ||
55 | - sys_lib_search_path_spec="" | ||
56 | -fi | ||
57 | - | ||
58 | AC_PATH_PROGS(PERL, perl5 perl) | ||
59 | |||
60 | AC_PATH_PROG(MAN2HTML, man2html, no) | ||
diff --git a/recipes-graphics/directfb/directfb/fixsepbuild.patch b/recipes-graphics/directfb/directfb/fixsepbuild.patch deleted file mode 100644 index 94a9ba5f..00000000 --- a/recipes-graphics/directfb/directfb/fixsepbuild.patch +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | Fix out of tree builds | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | RP 2013/03/21 | ||
6 | |||
7 | Index: DirectFB-1.6.1/configure.in | ||
8 | =================================================================== | ||
9 | --- DirectFB-1.6.1.orig/configure.in 2013-03-19 01:38:28.174004720 +0000 | ||
10 | +++ DirectFB-1.6.1/configure.in 2013-03-21 12:18:10.253113675 +0000 | ||
11 | @@ -111,7 +111,7 @@ | ||
12 | AC_PATH_TOOL(FLUXCOMP, fluxcomp) | ||
13 | AC_SUBST(FLUXCOMP) | ||
14 | if test -z "$FLUXCOMP"; then | ||
15 | - if ! test -e src/core/CoreDFB.cpp; then | ||
16 | + if ! test -e $srcdir/src/core/CoreDFB.cpp; then | ||
17 | AC_MSG_ERROR([ | ||
18 | *** DirectFB compilation requires fluxcomp *** | ||
19 | |||
diff --git a/recipes-graphics/directfb/directfb/fusion.patch b/recipes-graphics/directfb/directfb/fusion.patch deleted file mode 100644 index 1f81a679..00000000 --- a/recipes-graphics/directfb/directfb/fusion.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | directfb: Fix for hangs in direct_test, fusion_skirmish on exit | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Lauren Post <lauren.post@freescale.com> | ||
5 | |||
6 | --- a/lib/fusion/fusion.c 2013-01-18 22:57:11.000000000 +0800 | ||
7 | +++ b/lib/fusion/fusion.c 2013-07-04 10:42:56.502699119 +0800 | ||
8 | @@ -2853,9 +2853,14 @@ | ||
9 | direct_mutex_lock( &world->event_dispatcher_mutex ); | ||
10 | |||
11 | while (1) { | ||
12 | - if (!world->event_dispatcher_buffers) | ||
13 | + if (!world->event_dispatcher_buffers){ | ||
14 | direct_waitqueue_wait( &world->event_dispatcher_cond, &world->event_dispatcher_mutex ); | ||
15 | - | ||
16 | + if (world->dispatch_stop) { | ||
17 | + D_DEBUG_AT( Fusion_Main_Dispatch, " -> IGNORING (dispatch_stop!)\n" ); | ||
18 | + direct_mutex_unlock( &world->event_dispatcher_mutex ); | ||
19 | + return NULL; | ||
20 | + } | ||
21 | + } | ||
22 | buf = (FusionEventDispatcherBuffer *)world->event_dispatcher_buffers; | ||
23 | D_MAGIC_ASSERT( buf, FusionEventDispatcherBuffer ); | ||
24 | |||
25 | @@ -2872,6 +2877,11 @@ | ||
26 | //D_INFO("waiting...\n"); | ||
27 | D_ASSERT( buf->read_pos == buf->write_pos ); | ||
28 | direct_waitqueue_wait( &world->event_dispatcher_cond, &world->event_dispatcher_mutex ); | ||
29 | + if (world->dispatch_stop) { | ||
30 | + D_DEBUG_AT( Fusion_Main_Dispatch, " -> IGNORING (dispatch_stop!)\n" ); | ||
31 | + direct_mutex_unlock( &world->event_dispatcher_mutex ); | ||
32 | + return NULL; | ||
33 | + } | ||
34 | } | ||
35 | |||
36 | buf = (FusionEventDispatcherBuffer *)world->event_dispatcher_buffers; | ||
diff --git a/recipes-graphics/directfb/directfb_%.bbappend b/recipes-graphics/directfb/directfb_%.bbappend deleted file mode 100644 index a95af537..00000000 --- a/recipes-graphics/directfb/directfb_%.bbappend +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | # i.MX6 has DirectFB acceleration support, so add it | ||
2 | RDEPENDS_${PN}_append_mx6 = " libvivante-dfb-mx6" | ||
3 | PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}" | ||
diff --git a/recipes-graphics/directfb/directfb_1.7.4.bb b/recipes-graphics/directfb/directfb_1.7.4.bb deleted file mode 100644 index 8586f0c3..00000000 --- a/recipes-graphics/directfb/directfb_1.7.4.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | require directfb.inc | ||
2 | |||
3 | RV = "1.7-4" | ||
4 | |||
5 | DEPENDS += "sysfsutils" | ||
6 | |||
7 | SRC_URI += "file://fixsepbuild.patch \ | ||
8 | file://Check-input-NULL-pointer.patch" | ||
9 | |||
10 | EXTRA_OECONF = "\ | ||
11 | --enable-freetype=yes \ | ||
12 | --enable-zlib \ | ||
13 | --with-gfxdrivers=none \ | ||
14 | --disable-sdl \ | ||
15 | --disable-vnc \ | ||
16 | --disable-x11 \ | ||
17 | --disable-imlib2 \ | ||
18 | --disable-mesa \ | ||
19 | --with-tests \ | ||
20 | " | ||
21 | LEAD_SONAME = "libdirectfb-1.7.so.0" | ||
22 | |||
23 | SRC_URI[md5sum] = "f5bdacde77fc653279819796ae11341e" | ||
24 | SRC_URI[sha256sum] = "20ccd60011c788e50c940ab566943d050679067bc84dc37ca447f1b4af08481b" | ||
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc index 78e1e32a..2c62711d 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv.inc | |||
@@ -36,7 +36,6 @@ PACKAGES =+ "libclc-mx6 libclc-mx6-dev libclc-mx6-dbg \ | |||
36 | libgal-mx6 libgal-mx6-dev libgal-mx6-dbg \ | 36 | libgal-mx6 libgal-mx6-dev libgal-mx6-dbg \ |
37 | libvivante-mx6 libvivante-mx6-dev libvivante-mx6-dbg \ | 37 | libvivante-mx6 libvivante-mx6-dev libvivante-mx6-dbg \ |
38 | libvivante-dri-mx6 \ | 38 | libvivante-dri-mx6 \ |
39 | libvivante-dfb-mx6 \ | ||
40 | libvsc-mx6 \ | 39 | libvsc-mx6 \ |
41 | libwayland-viv-mx6 libwayland-viv-mx6-dev libwayland-viv-mx6-dbg \ | 40 | libwayland-viv-mx6 libwayland-viv-mx6-dev libwayland-viv-mx6-dbg \ |
42 | libgc-wayland-protocol-mx6 libgc-wayland-protocol-mx6-dev libgc-wayland-protocol-mx6-dbg \ | 41 | libgc-wayland-protocol-mx6 libgc-wayland-protocol-mx6-dev libgc-wayland-protocol-mx6-dbg \ |
@@ -64,7 +63,6 @@ python __anonymous () { | |||
64 | } | 63 | } |
65 | 64 | ||
66 | USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}" | 65 | USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}" |
67 | USE_DFB = "${@base_contains("DISTRO_FEATURES", "directfb", "yes", "no", d)}" | ||
68 | USE_WL = "${@base_contains("DISTRO_FEATURES", "wayland", "yes", "no", d)}" | 66 | USE_WL = "${@base_contains("DISTRO_FEATURES", "wayland", "yes", "no", d)}" |
69 | 67 | ||
70 | # Inhibit warnings about files being stripped. | 68 | # Inhibit warnings about files being stripped. |
@@ -122,7 +120,7 @@ do_install () { | |||
122 | 120 | ||
123 | install -d ${D}${libdir}/pkgconfig | 121 | install -d ${D}${libdir}/pkgconfig |
124 | 122 | ||
125 | # The preference order, based in DISTRO_FEATURES, is x11, wayland, directfb and fb | 123 | # The preference order, based in DISTRO_FEATURES, is x11, wayland and fb |
126 | if [ "${USE_X11}" = "yes" ]; then | 124 | if [ "${USE_X11}" = "yes" ]; then |
127 | cp -r ${S}/gpu-core/usr/lib/dri ${D}${libdir} | 125 | cp -r ${S}/gpu-core/usr/lib/dri ${D}${libdir} |
128 | cp -r ${S}/apitrace/x11/usr/lib/* ${D}${libdir} | 126 | cp -r ${S}/apitrace/x11/usr/lib/* ${D}${libdir} |
@@ -154,26 +152,15 @@ do_install () { | |||
154 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/wayland-egl.pc ${D}${libdir}/pkgconfig/wayland-egl.pc | 152 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/wayland-egl.pc ${D}${libdir}/pkgconfig/wayland-egl.pc |
155 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/wayland-viv.pc ${D}${libdir}/pkgconfig/wayland-viv.pc | 153 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/wayland-viv.pc ${D}${libdir}/pkgconfig/wayland-viv.pc |
156 | else | 154 | else |
155 | # Regular framebuffer | ||
157 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv1_cm.pc ${D}${libdir}/pkgconfig/glesv1_cm.pc | 156 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv1_cm.pc ${D}${libdir}/pkgconfig/glesv1_cm.pc |
158 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv2.pc ${D}${libdir}/pkgconfig/glesv2.pc | 157 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/glesv2.pc ${D}${libdir}/pkgconfig/glesv2.pc |
159 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/vg.pc ${D}${libdir}/pkgconfig/vg.pc | 158 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/vg.pc ${D}${libdir}/pkgconfig/vg.pc |
160 | 159 | ||
161 | if [ "${USE_DFB}" = "yes" ]; then | 160 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl_linuxfb.pc ${D}${libdir}/pkgconfig/egl.pc |
162 | install -d ${D}/${sysconfdir} | 161 | cp -r ${S}/apitrace/non-x11/usr/lib/* ${D}${libdir} |
163 | install -m 644 ${S}/gpu-core/etc/directfbrc ${D}/${sysconfdir}/directfbrc | 162 | cp -r ${S}/apitrace/non-x11/usr/bin/* ${D}${bindir} |
164 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl_directfb.pc ${D}${libdir}/pkgconfig/egl.pc | 163 | backend=fb |
165 | |||
166 | cp -r ${S}/gpu-core/usr/lib/directfb-* ${D}${libdir} | ||
167 | cp -r ${S}/apitrace/non-x11/usr/lib/* ${D}${libdir} | ||
168 | cp -r ${S}/apitrace/non-x11/usr/bin/* ${D}${bindir} | ||
169 | backend=dfb | ||
170 | else | ||
171 | # Regular framebuffer | ||
172 | install -m 0644 ${S}/gpu-core/usr/lib/pkgconfig/egl_linuxfb.pc ${D}${libdir}/pkgconfig/egl.pc | ||
173 | cp -r ${S}/apitrace/non-x11/usr/lib/* ${D}${libdir} | ||
174 | cp -r ${S}/apitrace/non-x11/usr/bin/* ${D}${bindir} | ||
175 | backend=fb | ||
176 | fi | ||
177 | fi | 164 | fi |
178 | 165 | ||
179 | # Install Vendor ICDs for OpenCL's installable client driver loader (ICDs Loader) | 166 | # Install Vendor ICDs for OpenCL's installable client driver loader (ICDs Loader) |
@@ -304,8 +291,6 @@ FILES_libvivante-mx6-dbg = "${libdir}/.debug/libVIVANTE${SOLIBS}" | |||
304 | FILES_libvivante-dri-mx6 = "${libdir}/dri/vivante_dri.so" | 291 | FILES_libvivante-dri-mx6 = "${libdir}/dri/vivante_dri.so" |
305 | RDEPENDS_libvivante-dri-mx6 = "libdrm" | 292 | RDEPENDS_libvivante-dri-mx6 = "libdrm" |
306 | 293 | ||
307 | FILES_libvivante-dfb-mx6 = "${libdir}/directfb-*/gfxdrivers/libdirectfb_gal.so" | ||
308 | |||
309 | INSANE_SKIP_libwayland-viv-mx6 += "dev-so" | 294 | INSANE_SKIP_libwayland-viv-mx6 += "dev-so" |
310 | FILES_libwayland-viv-mx6 = "${libdir}/libwayland-viv${REALSOLIBS} ${libdir}/libwayland-viv${SOLIBS}" | 295 | FILES_libwayland-viv-mx6 = "${libdir}/libwayland-viv${REALSOLIBS} ${libdir}/libwayland-viv${SOLIBS}" |
311 | FILES_libwayland-viv-mx6-dev = "${includedir}/wayland-viv ${libdir})/libwayland-viv${SOLIBSDEV} ${libdir}/pkgconfig/wayland-viv.pc" | 296 | FILES_libwayland-viv-mx6-dev = "${includedir}/wayland-viv ${libdir})/libwayland-viv${SOLIBSDEV} ${libdir}/pkgconfig/wayland-viv.pc" |
@@ -318,8 +303,6 @@ FILES_libgc-wayland-protocol-mx6-dbg = "${libdir}/libgc_wayland_protocol${SOLIBS | |||
318 | 303 | ||
319 | FILES_libwayland-egl-mx6-dev = "${libdir}/pkgconfig/wayland-egl.pc" | 304 | FILES_libwayland-egl-mx6-dev = "${libdir}/pkgconfig/wayland-egl.pc" |
320 | 305 | ||
321 | FILES_libvivante-dfb-mx6 += "${sysconfdir}/directfbrc" | ||
322 | |||
323 | INSANE_SKIP_imx-gpu-viv-g2d += "dev-so" | 306 | INSANE_SKIP_imx-gpu-viv-g2d += "dev-so" |
324 | FILES_imx-gpu-viv-g2d = "${libdir}/libg2d* " | 307 | FILES_imx-gpu-viv-g2d = "${libdir}/libg2d* " |
325 | FILES_imx-gpu-viv-g2d-dev = "${includedir}/g2d.h" | 308 | FILES_imx-gpu-viv-g2d-dev = "${includedir}/g2d.h" |