summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2016-11-18 19:11:49 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2016-11-23 08:09:34 -0200
commit8c8f8fcd87681c637a2cf3c198e1db06d712cefb (patch)
tree750436d1f0c8247acd4bce92a39b46e2b3a5d7d5 /recipes-graphics
parent4b573dd70221d821b75d3253a5222daf6ec877ff (diff)
downloadmeta-freescale-8c8f8fcd87681c637a2cf3c198e1db06d712cefb.tar.gz
weston: Use compiler settings provided by IMX-GPU driver pkg-config
The IMX-GPU driver now provides compiler settings through pkg-config, so don't set them explicitly. The package had to be patched to link the compositor to egl. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston/0016-Link-compositor-to-egl.patch12
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend23
2 files changed, 13 insertions, 22 deletions
diff --git a/recipes-graphics/wayland/weston/0016-Link-compositor-to-egl.patch b/recipes-graphics/wayland/weston/0016-Link-compositor-to-egl.patch
new file mode 100644
index 00000000..3cad74fd
--- /dev/null
+++ b/recipes-graphics/wayland/weston/0016-Link-compositor-to-egl.patch
@@ -0,0 +1,12 @@
1Index: weston-1.11.1/configure.ac
2===================================================================
3--- weston-1.11.1.orig/configure.ac 2016-11-08 17:26:14.266564760 -0600
4+++ weston-1.11.1/configure.ac 2016-11-09 19:38:58.000000000 -0600
5@@ -93,6 +93,7 @@
6 PKG_CHECK_MODULES(EGL, [egl glesv2])
7 PKG_CHECK_MODULES([EGL_TESTS], [egl glesv2 wayland-client wayland-egl])
8 PKG_CHECK_MODULES([GL_RENDERER], [libdrm])
9+ COMPOSITOR_MODULES="$COMPOSITOR_MODULES egl"
10 fi
11
12 AC_ARG_ENABLE(xkbcommon,
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index 366398f0..dbe87f14 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -14,6 +14,7 @@ SRC_URI_append_imxgpu2d = " \
14 file://0013-MGS-1945-Use-common-API-to-support-G2d-compositor.patch \ 14 file://0013-MGS-1945-Use-common-API-to-support-G2d-compositor.patch \
15 file://0014-MGS-1987-Get-stride-from-the-FB-buffe.patch \ 15 file://0014-MGS-1987-Get-stride-from-the-FB-buffe.patch \
16 file://0015-MGS-2221-imx-171-Fix-weston-build-failed.patch \ 16 file://0015-MGS-2221-imx-171-Fix-weston-build-failed.patch \
17 file://0016-Link-compositor-to-egl.patch \
17" 18"
18 19
19PACKAGECONFIG_IMX_TO_APPEND = "" 20PACKAGECONFIG_IMX_TO_APPEND = ""
@@ -37,25 +38,3 @@ EXTRA_OECONF_IMX_imxpxp = "${EXTRA_OECONF_IMX_COMMON}"
37EXTRA_OECONF_IMX_imxgpu2d = "${EXTRA_OECONF_IMX_COMMON}" 38EXTRA_OECONF_IMX_imxgpu2d = "${EXTRA_OECONF_IMX_COMMON}"
38 39
39EXTRA_OECONF_append = " ${EXTRA_OECONF_IMX}" 40EXTRA_OECONF_append = " ${EXTRA_OECONF_IMX}"
40
41# Use a intermediate step to configure the linking flags
42IMXGPU_LIBS = ""
43IMXGPU_LIBS_imxgpu2d = " \
44 COMPOSITOR_LIBS="-lEGL -lGAL -lwayland-server -lxkbcommon -lpixman-1" \
45 FB_COMPOSITOR_LIBS="-lEGL -lwayland-server -lxkbcommon" \
46"
47IMXGPU_LIBS_imxgpu3d = " \
48 COMPOSITOR_LIBS="-lGLESv2 -lEGL -lGAL -lwayland-server -lxkbcommon -lpixman-1" \
49 FB_COMPOSITOR_LIBS="-lGLESv2 -lEGL -lwayland-server -lxkbcommon" \
50"
51
52# Use the linking flags according to the GPU support
53EXTRA_OEMAKE_append_imxgpu2d = " \
54 COMPOSITOR_CFLAGS="-I ${STAGING_INCDIR}/pixman-1 -DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \
55 FB_COMPOSITOR_CFLAGS="-DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \
56 SIMPLE_EGL_CLIENT_CFLAGS="-DLINUX -DEGL_API_FB -DEGL_API_WL" \
57 EGL_TESTS_CFLAGS="-DLINUX -DEGL_API_FB -DEGL_API_WL" \
58 CLIENT_CFLAGS="-I ${STAGING_INCDIR}/cairo -I ${STAGING_INCDIR}/pixman-1 -DLINUX -DEGL_API_FB -DEGL_API_WL" \
59 \
60 ${IMXGPU_LIBS} \
61"