diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-09-19 17:27:33 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-09-19 17:33:14 -0500 |
commit | ee92b5a8b2cad45de267d3cf6dae9251f5ed11fd (patch) | |
tree | 7a93b31de339dc8506d8ad9e33340c3153585178 /recipes-graphics | |
parent | 77a4c34155fa0eb46350e1e46ae8c5138b6117d5 (diff) | |
download | meta-freescale-ee92b5a8b2cad45de267d3cf6dae9251f5ed11fd.tar.gz |
imx-gpu-viv: Mark libvulkan-imx unavailable for 8M Mini
The GPU drivers do not support 8M Mini, so properly exclude them from
PACKAGES so the user gets an earlier indication of a problem:
```
$ bitbake vulkan-loader
ERROR: Nothing RPROVIDES 'libvulkan-imx' (but /.../poky/meta/recipes-graphics/vulkan/vulkan-loader_1.3.216.0.bb RDEPENDS on or otherwise requires it)
ERROR: Required build target 'vulkan-loader' has no buildable providers.
Missing or unbuildable dependency chain was: ['vulkan-loader', 'libvulkan-imx']
```
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 11 |
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index 4abab088..e95761a1 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -71,8 +71,6 @@ PACKAGECONFIG ?= "" | |||
71 | PACKAGECONFIG[valgrind] = "" | 71 | PACKAGECONFIG[valgrind] = "" |
72 | 72 | ||
73 | # Note : If you add a package here, to prevent a naming conflict see the python_anonymous() futher below | 73 | # Note : If you add a package here, to prevent a naming conflict see the python_anonymous() futher below |
74 | IMX_PACKAGES_GBM = "" | ||
75 | IMX_PACKAGES_GBM:mx8-nxp-bsp = "libgbm-imx libgbm-imx-dev" | ||
76 | PACKAGES =+ "libclc-imx libclc-imx-dev \ | 74 | PACKAGES =+ "libclc-imx libclc-imx-dev \ |
77 | libgl-imx libgl-imx-dev \ | 75 | libgl-imx libgl-imx-dev \ |
78 | libgles1-imx libgles1-imx-dev \ | 76 | libgles1-imx libgles1-imx-dev \ |
@@ -85,13 +83,18 @@ PACKAGES =+ "libclc-imx libclc-imx-dev \ | |||
85 | libegl-imx libegl-imx-dev \ | 83 | libegl-imx libegl-imx-dev \ |
86 | libgal-imx libgal-imx-dev \ | 84 | libgal-imx libgal-imx-dev \ |
87 | libvsc-imx \ | 85 | libvsc-imx \ |
88 | ${IMX_PACKAGES_GBM} \ | 86 | ${PACKAGES_GBM} \ |
89 | imx-gpu-viv-tools \ | 87 | imx-gpu-viv-tools \ |
90 | imx-gpu-viv-demos \ | 88 | imx-gpu-viv-demos \ |
91 | libvulkan-imx libvulkan-imx-dev \ | 89 | ${PACKAGES_VULKAN} \ |
92 | libopenvx-imx libopenvx-imx-dev \ | 90 | libopenvx-imx libopenvx-imx-dev \ |
93 | libnn-imx \ | 91 | libnn-imx \ |
94 | " | 92 | " |
93 | PACKAGES_GBM = "" | ||
94 | PACKAGES_GBM:mx8-nxp-bsp = "libgbm-imx libgbm-imx-dev" | ||
95 | PACKAGES_VULKAN = "" | ||
96 | PACKAGES_VULKAN:aarch64 = "libvulkan-imx libvulkan-imx-dev" | ||
97 | PACKAGES_VULKAN:mx8mm-nxp-bsp = "" | ||
95 | python __anonymous () { | 98 | python __anonymous () { |
96 | has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT') or '0') | 99 | has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT') or '0') |
97 | if has_vivante_kernel_driver_support != '1': | 100 | if has_vivante_kernel_driver_support != '1': |