diff options
author | Gary Bisson <gary.bisson@boundarydevices.com> | 2023-01-05 11:24:14 +0100 |
---|---|---|
committer | Gary Bisson <gary.bisson@boundarydevices.com> | 2023-01-06 17:15:40 +0100 |
commit | 599d4aa186656e5eb709ebf26ef72b93234e37b2 (patch) | |
tree | 17ff50dfadea0883be75e77ac73050daf9777e75 /recipes-graphics | |
parent | 1fec75c2b290add66471cef866165c31bef32fb3 (diff) | |
download | meta-freescale-599d4aa186656e5eb709ebf26ef72b93234e37b2.tar.gz |
imx-gpu-g2d: update from 6.4.3.p4.4 to 6.4.3.p4.6
- Update to the version used in NXP Yocto branch kirkstone-5.15.71-2.2.0
- The 8M Mini does not support OpenCL, so install an SOC-specific G2D
library built without OpenCL. (see e3e0817b in meta-imx)
- Also the binaries seem to be stripped now, so skip that step to avoid
build errors
Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb | 33 | ||||
-rw-r--r-- | recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.6.bb | 46 |
2 files changed, 46 insertions, 33 deletions
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb deleted file mode 100644 index 524f15e9..00000000 --- a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2022 NXP | ||
3 | # Copyright 2018 (C) O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "G2D library using i.MX GPU" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" | ||
9 | DEPENDS = "libgal-imx" | ||
10 | PROVIDES = "virtual/libg2d" | ||
11 | |||
12 | FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}" | ||
13 | |||
14 | SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true" | ||
15 | SRC_URI[aarch64.md5sum] = "98d46bca2ae66e31b7e4878a7b622b99" | ||
16 | SRC_URI[aarch64.sha256sum] = "8341d6e2cde3f3ffa035dc95b0487dd04a50531cc80f4cddc5a689ebc4946e02" | ||
17 | SRC_URI[arm.md5sum] = "ff96d069092424a50ba4542d6ef5e931" | ||
18 | SRC_URI[arm.sha256sum] = "7737a3372bcde34e2d275397df67c307df5033d5b133ac770f75cac4e1ec2580" | ||
19 | |||
20 | S = "${WORKDIR}/${FSLBIN_NAME}" | ||
21 | |||
22 | inherit fsl-eula-unpack | ||
23 | |||
24 | do_install () { | ||
25 | install -d ${D}${libdir} | ||
26 | install -d ${D}${includedir} | ||
27 | cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
28 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
29 | } | ||
30 | |||
31 | INSANE_SKIP:${PN} = "ldflags" | ||
32 | |||
33 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.6.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.6.bb new file mode 100644 index 00000000..d513c720 --- /dev/null +++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.6.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2022 NXP | ||
3 | # Copyright 2018 (C) O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "G2D library using i.MX GPU" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" | ||
9 | DEPENDS = "libgal-imx" | ||
10 | PROVIDES = "virtual/libg2d" | ||
11 | |||
12 | FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}" | ||
13 | |||
14 | SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true" | ||
15 | SRC_URI[aarch64.md5sum] = "41e6c3a6f8d4151d30c1f34341465b30" | ||
16 | SRC_URI[aarch64.sha256sum] = "70e007f66459ee6a392f4a21f4d4a753ff22a75b728cc7d952251b00ba3ab51e" | ||
17 | SRC_URI[arm.md5sum] = "4c751218aa4db1f545bcec17ee963cc0" | ||
18 | SRC_URI[arm.sha256sum] = "288f78419d825e71563c38a39a738f040e098b581b76e6f8b8fc5895e7d9d7c4" | ||
19 | |||
20 | S = "${WORKDIR}/${FSLBIN_NAME}" | ||
21 | |||
22 | inherit fsl-eula-unpack | ||
23 | |||
24 | SOC_INSTALL_DIR = "SOC_INSTALL_DIR_NOT_SET" | ||
25 | SOC_INSTALL_DIR:mx8mm-nxp-bsp = "mx8mm" | ||
26 | |||
27 | do_install () { | ||
28 | install -d ${D}${libdir} | ||
29 | install -d ${D}${includedir} | ||
30 | cp -d ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
31 | if [ -d ${S}/g2d/usr/lib/${SOC_INSTALL_DIR} ]; then | ||
32 | cp -d ${S}/g2d/usr/lib/${SOC_INSTALL_DIR}/*.so* ${D}${libdir} | ||
33 | fi | ||
34 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
35 | } | ||
36 | |||
37 | # The packaged binaries have been stripped of debug info, so disable | ||
38 | # operations accordingly. | ||
39 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
40 | INHIBIT_PACKAGE_STRIP = "1" | ||
41 | INHIBIT_SYSROOT_STRIP = "1" | ||
42 | |||
43 | INSANE_SKIP:${PN} = "ldflags" | ||
44 | |||
45 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||
46 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||