diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2021-04-06 09:20:51 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-04-20 12:10:12 -0300 |
commit | 1ebb62d0f66ec7c74fe7b3f4d7dc751aa156f48f (patch) | |
tree | f93dca8c9d537be922aefb71d8aa5aba45b1e216 /recipes-graphics | |
parent | 71a0623ada456790778213a0ea2bb6b1535bd069 (diff) | |
download | meta-freescale-1ebb62d0f66ec7c74fe7b3f4d7dc751aa156f48f.tar.gz |
mesa-etnaviv-env: Add a recipe to set environment variables for mesa/entaviv
* we have several options to start an x-session. To not touch all, set
environment variables globally
* Inspired by [1]
[1] https://gitlab.freedesktop.org/mesa/mesa/-/issues/3721
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.conf | 3 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb | 24 |
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.conf b/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.conf new file mode 100644 index 00000000..db4f8740 --- /dev/null +++ b/recipes-graphics/mesa/mesa-etnaviv-env/mesa-etnaviv.conf | |||
@@ -0,0 +1,3 @@ | |||
1 | [Manager] | ||
2 | DefaultEnvironment=MESA_GL_VERSION_OVERRIDE=2.1 ETNA_MESA_DEBUG=nir | ||
3 | |||
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb new file mode 100644 index 00000000..13cdf02d --- /dev/null +++ b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "Mesa environment variables for etnaviv on xserver" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" | ||
4 | |||
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
6 | |||
7 | SRC_URI = "file://mesa-etnaviv.conf" | ||
8 | |||
9 | do_configure[noexec] = "1" | ||
10 | do_compile[noexec] = "1" | ||
11 | |||
12 | do_install() { | ||
13 | # MESA global envirronment variables | ||
14 | |||
15 | # systemd | ||
16 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
17 | install -D -m 644 ${WORKDIR}/mesa-etnaviv.conf \ | ||
18 | ${D}${sysconfdir}/systemd/system.conf.d/mesa-etnaviv.conf | ||
19 | fi | ||
20 | |||
21 | # sysvinit - TODO | ||
22 | } | ||
23 | |||
24 | ALLOW_EMPTY_${PN} = "1" | ||