diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2016-05-09 14:13:42 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-05-16 17:06:51 -0300 |
commit | 9908b92f4a4e5c4d9d7dbb648426b6e12cd1fe67 (patch) | |
tree | 8a09734fec2eea7dfdb258857ae41b576113f6b0 /recipes-graphics | |
parent | 1d625c03f00f2ea59e1dc5e178ad9cf510e5d75f (diff) | |
download | meta-freescale-9908b92f4a4e5c4d9d7dbb648426b6e12cd1fe67.tar.gz |
mesa-demos: Rebase patches due to OE-Core changes
Update patch Add-OpenVG-demos-to-support-wayland.patch due to
changes applied in OE-Core:b851cb0a.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch | 45 |
1 files changed, 15 insertions, 30 deletions
diff --git a/recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch b/recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch index 726d67ba..d87f7d26 100644 --- a/recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch +++ b/recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch | |||
@@ -11,11 +11,11 @@ Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | |||
11 | src/egl/openvg/Makefile.am | 33 +++++++++++++++++++++++++++++---- | 11 | src/egl/openvg/Makefile.am | 33 +++++++++++++++++++++++++++++---- |
12 | 2 files changed, 32 insertions(+), 7 deletions(-) | 12 | 2 files changed, 32 insertions(+), 7 deletions(-) |
13 | 13 | ||
14 | diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am | 14 | Index: mesa-demos-8.2.0/src/egl/Makefile.am |
15 | index 4fe1ca8..65f4570 100644 | 15 | =================================================================== |
16 | --- a/src/egl/Makefile.am | 16 | --- mesa-demos-8.2.0.orig/src/egl/Makefile.am 2016-05-09 11:45:51.479100180 -0500 |
17 | +++ b/src/egl/Makefile.am | 17 | +++ mesa-demos-8.2.0/src/egl/Makefile.am 2016-05-09 11:45:51.475100160 -0500 |
18 | @@ -26,10 +26,10 @@ SUBDIRS = \ | 18 | @@ -26,10 +26,10 @@ |
19 | eglut \ | 19 | eglut \ |
20 | opengles1 \ | 20 | opengles1 \ |
21 | opengles2 \ | 21 | opengles2 \ |
@@ -29,51 +29,39 @@ index 4fe1ca8..65f4570 100644 | |||
29 | - openvg | 29 | - openvg |
30 | + opengl | 30 | + opengl |
31 | endif | 31 | endif |
32 | diff --git a/src/egl/openvg/Makefile.am b/src/egl/openvg/Makefile.am | 32 | Index: mesa-demos-8.2.0/src/egl/openvg/Makefile.am |
33 | index b545225..a2e0d94 100644 | 33 | =================================================================== |
34 | --- a/src/egl/openvg/Makefile.am | 34 | --- mesa-demos-8.2.0.orig/src/egl/openvg/Makefile.am 2016-05-09 11:45:51.479100180 -0500 |
35 | +++ b/src/egl/openvg/Makefile.am | 35 | +++ mesa-demos-8.2.0/src/egl/openvg/Makefile.am 2016-05-09 12:39:30.000000000 -0500 |
36 | @@ -46,31 +46,56 @@ EGL_X11_DEMOS += \ | 36 | @@ -47,13 +47,26 @@ |
37 | text | ||
38 | endif | 37 | endif |
39 | endif | 38 | endif |
39 | |||
40 | +if HAVE_WAYLAND | 40 | +if HAVE_WAYLAND |
41 | +EGL_WL_DEMOS = \ | 41 | +EGL_WL_DEMOS = \ |
42 | + lion_wayland \ | 42 | + lion_wayland \ |
43 | + sp_wayland | 43 | + sp_wayland |
44 | 44 | + | |
45 | +if HAVE_FREETYPE2 | 45 | +if HAVE_FREETYPE2 |
46 | +EGL_WL_DEMOS += \ | 46 | +EGL_WL_DEMOS += \ |
47 | + vgtext_wayland | 47 | + vgtext_wayland |
48 | +endif | 48 | +endif |
49 | +endif | 49 | +endif |
50 | + | ||
50 | if HAVE_EGL | 51 | if HAVE_EGL |
51 | if HAVE_VG | 52 | if HAVE_VG |
52 | bin_PROGRAMS = \ | 53 | bin_PROGRAMS = \ |
53 | lion_screen \ | ||
54 | sp_screen \ | ||
55 | - $(EGL_X11_DEMOS) | 54 | - $(EGL_X11_DEMOS) |
56 | + $(EGL_X11_DEMOS) \ | 55 | + $(EGL_X11_DEMOS) \ |
57 | + $(EGL_WL_DEMOS) | 56 | + $(EGL_WL_DEMOS) |
58 | endif | 57 | endif |
59 | endif | 58 | endif |
60 | 59 | ||
61 | lion_screen_SOURCES = lion.c lion-render.c lion-render.h | ||
62 | +lion_screen_LDADD = ../eglut/libeglut_screen.la | ||
63 | + | ||
64 | sp_screen_SOURCES = sp.c | ||
65 | +sp_screen_LDADD = ../eglut/libeglut_screen.la | ||
66 | |||
67 | +if HAVE_X11 | 60 | +if HAVE_X11 |
68 | lion_x11_SOURCES = lion.c lion-render.c lion-render.h | 61 | lion_x11_SOURCES = lion.c lion-render.c lion-render.h |
69 | sp_x11_SOURCES = sp.c | 62 | sp_x11_SOURCES = sp.c |
70 | 63 | ||
71 | -lion_screen_LDADD = ../eglut/libeglut_screen.la | 64 | @@ -63,6 +76,20 @@ |
72 | -sp_screen_LDADD = ../eglut/libeglut_screen.la | ||
73 | - | ||
74 | lion_x11_LDADD = ../eglut/libeglut_x11.la | ||
75 | sp_x11_LDADD = ../eglut/libeglut_x11.la | ||
76 | |||
77 | text_SOURCES = text.c | 65 | text_SOURCES = text.c |
78 | text_CFLAGS = $(AM_CFLAGS) @FREETYPE2_CFLAGS@ | 66 | text_CFLAGS = $(AM_CFLAGS) @FREETYPE2_CFLAGS@ |
79 | text_LDADD = @FREETYPE2_LIBS@ ../eglut/libeglut_x11.la | 67 | text_LDADD = @FREETYPE2_LIBS@ ../eglut/libeglut_x11.la |
@@ -94,6 +82,3 @@ index b545225..a2e0d94 100644 | |||
94 | 82 | ||
95 | SUBDIRS = \ | 83 | SUBDIRS = \ |
96 | trivial | 84 | trivial |
97 | -- | ||
98 | 2.3.5 | ||
99 | |||