summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-06-25 21:11:46 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-11 14:17:47 -0300
commita9280cb755c260922f78c5b1c65f2760b407e859 (patch)
treedb31fd47a6ee6faaf628cb8da14cffe38bcb4b8e /recipes-graphics
parentbdd11dae356edbb59af6c47c0066c49b62935f9b (diff)
downloadmeta-freescale-a9280cb755c260922f78c5b1c65f2760b407e859.tar.gz
imx-base.inc: Add imxfbdev and imxdrm to MACHINEOVERRIDES_EXTENDER
- weston uses the imxfbdev override for backend configuration - imx-gpu-viv uses the imxdrm override for dependency configuration Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc2
-rw-r--r--recipes-graphics/wayland/weston_4.0.0.imx.bb9
2 files changed, 3 insertions, 8 deletions
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
index 75158444..f0e549f1 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
@@ -12,11 +12,11 @@ DEPENDS += " \
12 bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxdamage libxext libxfixes', \ 12 bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxdamage libxext libxfixes', \
13 '', d), d)} \ 13 '', d), d)} \
14" 14"
15DEPENDS += "libdrm"
16DEPENDS += " \ 15DEPENDS += " \
17 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb libxshmfence libxxf86vm', \ 16 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb libxshmfence libxxf86vm', \
18 '', d)} \ 17 '', d)} \
19" 18"
19DEPENDS_append_imxdrm = " libdrm wayland"
20 20
21# imx-gpu-viv does not provide everything it needs to for virtual/libgl 21# imx-gpu-viv does not provide everything it needs to for virtual/libgl
22# on x11 backend or on Wayland backend with XWayland support. 22# on x11 backend or on Wayland backend with XWayland support.
diff --git a/recipes-graphics/wayland/weston_4.0.0.imx.bb b/recipes-graphics/wayland/weston_4.0.0.imx.bb
index b8464719..fc6a65f7 100644
--- a/recipes-graphics/wayland/weston_4.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_4.0.0.imx.bb
@@ -40,19 +40,14 @@ EXTRA_OECONF_append_qemux86 = "\
40EXTRA_OECONF_append_qemux86-64 = "\ 40EXTRA_OECONF_append_qemux86-64 = "\
41 WESTON_NATIVE_BACKEND=fbdev-backend.so \ 41 WESTON_NATIVE_BACKEND=fbdev-backend.so \
42 " 42 "
43EXTRA_OECONF_append_mx6 = "\ 43EXTRA_OECONF_append_imxfbdev = "\
44 WESTON_NATIVE_BACKEND=fbdev-backend.so \
45 "
46EXTRA_OECONF_append_mx7 = "\
47 WESTON_NATIVE_BACKEND=fbdev-backend.so \ 44 WESTON_NATIVE_BACKEND=fbdev-backend.so \
48 " 45 "
49PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ 46PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \
50 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \ 47 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
51 ${@bb.utils.filter('DISTRO_FEATURES', 'opengl pam systemd x11', d)} \ 48 ${@bb.utils.filter('DISTRO_FEATURES', 'opengl pam systemd x11', d)} \
52 clients launch" 49 clients launch"
53# drm is not supported on mx6/mx7 50PACKAGECONFIG_remove_imxfbdev = "kms"
54PACKAGECONFIG_remove_mx6 = "kms"
55PACKAGECONFIG_remove_mx7 = "kms"
56PACKAGECONFIG_append_imxgpu2d = " imxg2d" 51PACKAGECONFIG_append_imxgpu2d = " imxg2d"
57PACKAGECONFIG_append_imxgpu3d = " cairo-glesv2" 52PACKAGECONFIG_append_imxgpu3d = " cairo-glesv2"
58# 53#