summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-01-22 16:25:50 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-03 07:57:42 -0300
commit9ff64ce89a6ebe6dbf9fb3ccd8e2cddb41e7f300 (patch)
tree191be5b79b0bf3e61f969ff589833481566e8e86 /recipes-graphics
parentb03ccfef7dd961c2986031e5a88f9dd2cb309f2f (diff)
downloadmeta-freescale-9ff64ce89a6ebe6dbf9fb3ccd8e2cddb41e7f300.tar.gz
mesa: Limit OSMesa to DRM and remove swrast
OSMesa was originally added for i.MX 8 only. This limitation was recently dropped accidentally. Additionally, the 8DualXLite has no GPU and fails to build: ``` | In file included from ../../../mesa-demos-8.4.0/src/osdemos/osdemo32.c:14: | ../../../mesa-demos-8.4.0/src/util/glut_wrap.h:9:12: fatal error: GL/glut.h: No such file or directory | 9 | # include <GL/glut.h> | | ^~~~~~~~~~~ | compilation terminated. ``` Fix the OSMesa configuration by limiting it to parts with DRM. Also, adding swrast prevents the use of hardware acceleration. Drop swrast. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 47394d05017483e7fd0cba5b927c76198bdfa062)
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 6b9b456c..3a087425 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -17,10 +17,9 @@ python () {
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
19 19
20# Enable OSMesa which also requires dri (classic) swrast 20# For NXP BSP, enable OSMesa for parts with DRM
21PACKAGECONFIG_remove_use-nxp-bsp = "gallium" 21PACKAGECONFIG_remove_use-nxp-bsp_imxdrm = "gallium"
22PACKAGECONFIG_append_use-nxp-bsp = " osmesa" 22PACKAGECONFIG_append_use-nxp-bsp_imxdrm = " osmesa"
23DRIDRIVERS_use-nxp-bsp = "swrast"
24 23
25BACKEND = \ 24BACKEND = \
26 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ 25 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \