summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2020-05-05 12:16:01 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2020-05-05 15:44:29 -0300
commit642c234e2f129214fdae09f8ba93987993688ed3 (patch)
treeb4fba85261c1283ddcbd261beccddc23e97068cd /recipes-graphics
parentd99ad3ba0dcaf759512fe098acfa5604d09968d6 (diff)
downloadmeta-freescale-642c234e2f129214fdae09f8ba93987993688ed3.tar.gz
weston: Restore partial clients for i.MX 6 and 7
The clients configuration for fbdev was recently removed from meta-freescale [1] because of the following error: ``` | Run-time dependency gbm found: NO (tried pkgconfig and cmake) | | clients/meson.build:134:4: ERROR: Problem encountered: weston-simple-dmabuf-egl requires gbm which was not found. If you rather not build this, drop "dmabuf-egl" from simple-clients option. ``` [1] eda44e49618610c13ebe4c026cd4981b404a1543 It was also removed for non-Wayland from OE-core [2] because of the following error in the same client dmabuf-egl: ``` clients/meson.build:141:4: ERROR: Problem encountered: weston-simple-dmabuf-egl requires option renderer-gl which is not enabled. If you rather not build this, drop "dmabuf-egl" from simple-clients option. ``` [2] 9b1d30810eeecb46b977c8eed68be69aef891312 Restore the working subset of clients. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston_8.0.0.imx.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-graphics/wayland/weston_8.0.0.imx.bb b/recipes-graphics/wayland/weston_8.0.0.imx.bb
index 294daadc..a021a54d 100644
--- a/recipes-graphics/wayland/weston_8.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_8.0.0.imx.bb
@@ -146,11 +146,15 @@ PACKAGECONFIG_OPENGL_imxgpu3d = "opengl"
146 146
147PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" 147PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}"
148 148
149PACKAGECONFIG_remove_imxfbdev = "kms clients" 149PACKAGECONFIG_remove_imxfbdev = "kms"
150PACKAGECONFIG_append_imxfbdev = " fbdev" 150PACKAGECONFIG_append_imxfbdev = " fbdev clients"
151PACKAGECONFIG_append_imxgpu = " imxgpu" 151PACKAGECONFIG_append_imxgpu = " imxgpu"
152PACKAGECONFIG_append_imxgpu2d = " imxg2d" 152PACKAGECONFIG_append_imxgpu2d = " imxg2d"
153 153
154# Clients support
155SIMPLE_CLIENTS = "all"
156SIMPLE_CLIENTS_imxfbdev = "damage,im,egl,shm,touch,dmabuf-v4l"
157PACKAGECONFIG[clients] = "-Dsimple-clients=${SIMPLE_CLIENTS} -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false"
154# Weston with i.MX GPU support 158# Weston with i.MX GPU support
155PACKAGECONFIG[imxgpu] = "-Dimxgpu=true,-Dimxgpu=false,virtual/egl" 159PACKAGECONFIG[imxgpu] = "-Dimxgpu=true,-Dimxgpu=false,virtual/egl"
156# Weston with i.MX G2D renderer 160# Weston with i.MX G2D renderer