summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-09-02 16:49:45 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:19 -0300
commit0151cf31a1778667503b8d727a9313ed4bf0bee4 (patch)
tree572036222332746c06c4f7d799eab9687c22b8e4 /recipes-graphics
parent574898eb75e55aaaf87157e4ca12e81cbc85cd81 (diff)
downloadmeta-freescale-0151cf31a1778667503b8d727a9313ed4bf0bee4.tar.gz
Rework i.MX6 UltraLite support to not use other i.MX6 code
The i.MX6 UltraLite is very different from the other i.MX6 SoCs and the current BSP infrastructure needs to be reworked to allow for more granullar control of the features each SoC provide to control the changes to be applied for the SoC peripherals support. For now, it is not possible to express this clearly in the BSP so the current change is to revert some of the changes done for the i.MX6 UltraLite to be enabled and make sure that the boards using the SoC does not inherit the 'mx6' override. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/directfb/directfb_%.bbappend13
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend20
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend21
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend7
4 files changed, 15 insertions, 46 deletions
diff --git a/recipes-graphics/directfb/directfb_%.bbappend b/recipes-graphics/directfb/directfb_%.bbappend
index 20aa642e..a95af537 100644
--- a/recipes-graphics/directfb/directfb_%.bbappend
+++ b/recipes-graphics/directfb/directfb_%.bbappend
@@ -1,12 +1,3 @@
1# i.MX6 has DirectFB acceleration support, so add it 1# i.MX6 has DirectFB acceleration support, so add it
2RDEPENDS_${PN}_append_mx6q = " libvivante-dfb-mx6" 2RDEPENDS_${PN}_append_mx6 = " libvivante-dfb-mx6"
3PACKAGE_ARCH_mx6q = "${MACHINE_ARCH}" 3PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"
4
5RDEPENDS_${PN}_append_mx6dl = " libvivante-dfb-mx6"
6PACKAGE_ARCH_mx6dl = "${MACHINE_ARCH}"
7
8RDEPENDS_${PN}_append_mx6sx = " libvivante-dfb-mx6"
9PACKAGE_ARCH_mx6sx = "${MACHINE_ARCH}"
10
11RDEPENDS_${PN}_append_mx6sl = " libvivante-dfb-mx6"
12PACKAGE_ARCH_mx6sl = "${MACHINE_ARCH}"
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index cc245b22..1f070a44 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -1,24 +1,14 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3MESA-DEMO-PATCH = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ 3SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \
4 file://fix-clear-build-break.patch \ 4 file://fix-clear-build-break.patch \
5 file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ 5 file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \
6 file://Add-OpenVG-demos-to-support-wayland.patch" 6 file://Add-OpenVG-demos-to-support-wayland.patch"
7 7
8# only apply patches on mx6 that have a GPU 8PACKAGECONFIG_remove_mx6 = " \
9SRC_URI_append_mx6q = " ${MESA-DEMO-PATCH}" 9 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
10SRC_URI_append_mx6dl = " ${MESA-DEMO-PATCH}" 10 bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}"
11SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}" 11PACKAGECONFIG_remove_mx6sl = "gles1 gles2"
12SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}"
13
14REMOVE_GLU = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
15 bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}"
16
17# only remove GLU on mx6 thave have a GPU
18PACKAGECONFIG_remove_mx6q = "${REMOVE_GLU}"
19PACKAGECONFIG_remove_mx6dl = "${REMOVE_GLU}"
20PACKAGECONFIG_remove_mx6sx = "${REMOVE_GLU}"
21PACKAGECONFIG_remove_mx6sl = "gles1 gles2 ${REMOVE_GLU}"
22 12
23PACKAGECONFIG_append = "\ 13PACKAGECONFIG_append = "\
24 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ 14 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 66913e17..2536afd6 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,19 +1,12 @@
1PACKAGECONFIG_remove_mx6q = "egl gles" 1PACKAGECONFIG_remove_mx6 = "egl gles"
2PACKAGECONFIG_remove_mx6dl = "egl gles"
3PACKAGECONFIG_remove_mx6sx = "egl gles"
4PACKAGECONFIG_remove_mx6sl = "egl gles"
5 2
6# i.MX6SL uses mesa software rendering 3PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl"
4PROVIDES_remove_mx6q = "virtual/libgl"
5PROVIDES_remove_mx6dl = "virtual/libgl"
6PROVIDES_remove_mx6sx = "virtual/libgl"
7 7
8PROVIDES_remove_mx6q = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" 8USE_VIV_LIBGL = "yes"
9PROVIDES_remove_mx6dl = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" 9USE_VIV_LIBGL_mx6sl = "no"
10PROVIDES_remove_mx6sx = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl"
11PROVIDES_remove_mx6sl = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl"
12
13USE_VIV_LIBGL = "no"
14USE_VIV_LIBGL_mx6q = "yes"
15USE_VIV_LIBGL_mx6dl = "yes"
16USE_VIV_LIBGL_mx6sx = "yes"
17 10
18# FIXME: mesa should support 'x11-no-tls' option 11# FIXME: mesa should support 'x11-no-tls' option
19python () { 12python () {
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index a254f07f..a7496daa 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -1,11 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3# only install patch for mx6 with a GPU 3SRC_URI_append_mx6 = " file://0001-MGS-840-Add-i.MX6-support-for-weston.patch"
4GPU_PATCH = "file://0001-MGS-840-Add-i.MX6-support-for-weston.patch"
5SRC_URI_append_mx6q = " ${GPU_PATCH}"
6SRC_URI_append_mx6dl = " ${GPU_PATCH}"
7SRC_URI_append_mx6sx = " ${GPU_PATCH}"
8SRC_URI_append_mx6sl = " ${GPU_PATCH}"
9 4
10PACKAGECONFIG_append_mx6q = " cairo-glesv2" 5PACKAGECONFIG_append_mx6q = " cairo-glesv2"
11PACKAGECONFIG_append_mx6dl = " cairo-glesv2" 6PACKAGECONFIG_append_mx6dl = " cairo-glesv2"