diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-05-11 20:32:35 -0500 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2022-05-12 10:31:57 +0000 |
commit | 3b96ac30dd55452cc2916a180e9914fe9dd1552c (patch) | |
tree | ad1fb37b1963b9392fb5dbb375dece6c2f669235 /recipes-graphics | |
parent | b4fbbf154b1bcc59831bc4a24c3ab16382bb7aef (diff) | |
download | meta-freescale-3b96ac30dd55452cc2916a180e9914fe9dd1552c.tar.gz |
xwayland: Add patch to prefer GLES2 for glamor EGL
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
(cherry picked from commit a4f772cab24996be79e6dfc26f0b7a3c740468ca)
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/xwayland/xwayland/0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch | 31 | ||||
-rw-r--r-- | recipes-graphics/xwayland/xwayland_%.bbappend | 6 |
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-graphics/xwayland/xwayland/0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch b/recipes-graphics/xwayland/xwayland/0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch new file mode 100644 index 00000000..c1e8ae11 --- /dev/null +++ b/recipes-graphics/xwayland/xwayland/0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From e75a4d7b4474529967490de6e75ae4f1b7128937 Mon Sep 17 00:00:00 2001 | ||
2 | From: Xianzhong <xianzhong.li@nxp.com> | ||
3 | Date: Sat, 22 Jan 2022 17:57:59 +0800 | ||
4 | Subject: [PATCH 1/3] Prefer to create GLES2 context for glamor EGL | ||
5 | |||
6 | created the initial patch for xwayland-21.1.2 | ||
7 | |||
8 | Upstream-Status: Inappropriate [embedded specific] | ||
9 | Signed-off-by: Xianzhong <xianzhong.li@nxp.com> | ||
10 | --- | ||
11 | hw/xwayland/xwayland-glamor-gbm.c | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/hw/xwayland/xwayland-glamor-gbm.c b/hw/xwayland/xwayland-glamor-gbm.c | ||
15 | index 12d820e44..8a89919be 100644 | ||
16 | --- a/hw/xwayland/xwayland-glamor-gbm.c | ||
17 | +++ b/hw/xwayland/xwayland-glamor-gbm.c | ||
18 | @@ -866,8 +866,8 @@ xwl_glamor_gbm_init_egl(struct xwl_screen *xwl_screen) | ||
19 | goto error; | ||
20 | } | ||
21 | |||
22 | - if (!xwl_glamor_try_big_gl_api(xwl_screen) && | ||
23 | - !xwl_glamor_try_gles_api(xwl_screen)) { | ||
24 | + if (!xwl_glamor_try_gles_api(xwl_screen) && | ||
25 | + !xwl_glamor_try_big_gl_api(xwl_screen)) { | ||
26 | ErrorF("Cannot use neither GL nor GLES2\n"); | ||
27 | goto error; | ||
28 | } | ||
29 | -- | ||
30 | 2.17.1 | ||
31 | |||
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend index 9bf4f9bd..211d07a2 100644 --- a/recipes-graphics/xwayland/xwayland_%.bbappend +++ b/recipes-graphics/xwayland/xwayland_%.bbappend | |||
@@ -1,3 +1,9 @@ | |||
1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI:append:imxgpu = " \ | ||
4 | file://0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch \ | ||
5 | " | ||
6 | |||
1 | OPENGL_PKGCONFIGS:remove:imxgpu = "${OPENGL_PKGCONFIGS_REMOVE_IMXGPU}" | 7 | OPENGL_PKGCONFIGS:remove:imxgpu = "${OPENGL_PKGCONFIGS_REMOVE_IMXGPU}" |
2 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU = "" | 8 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU = "" |
3 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" | 9 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" |