summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-09-18 16:21:54 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:19 -0300
commit0045ccfd1e17246600f7153ffc4a7633eaacd5e1 (patch)
tree5d58f996f79cd08525107fbfc5a4e0bf3179e308 /recipes-graphics
parent22749cfe03023dfc52845f9ad16e4c3951b2fdde (diff)
downloadmeta-freescale-0045ccfd1e17246600f7153ffc4a7633eaacd5e1.tar.gz
directfb: Include a custom directfb.inc
The OE-Core commit: commit 8a577fa7cf54db646f4e61f383390054e5f04ca3 Author: Khem Raj <raj.khem@gmail.com> Date: Tue Sep 8 22:12:46 2015 +0000 directfb: Avoid using VLAs and printf formats These are not portable features and are flagged by clang Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Broke the directfb build as the new patch has been applied in the .inc file and was unconditionally being included. The patch was include for new versions of DirectFB and we ought to avoid including changes from OE-Core, for this recipe, without notice. It is likely the patch needs to be ported later for the forked DirectFB recipe but this is should be done afterwards. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/directfb/directfb.inc79
-rw-r--r--recipes-graphics/directfb/directfb_1.7.4.bb2
2 files changed, 80 insertions, 1 deletions
diff --git a/recipes-graphics/directfb/directfb.inc b/recipes-graphics/directfb/directfb.inc
new file mode 100644
index 00000000..9e909422
--- /dev/null
+++ b/recipes-graphics/directfb/directfb.inc
@@ -0,0 +1,79 @@
1SUMMARY = "Graphics abstraction library for the Linux Framebuffer Device"
2DESCRIPTION = "DirectFB is a thin library that provides developers \
3with hardware graphics acceleration, input device handling and \
4abstraction, an integrated windowing system with support for \
5translucent windows and multiple display layers on top of the \
6Linux framebuffer device."
7SECTION = "libs"
8LICENSE = "LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589"
10
11HOMEPAGE = "http://directfb.org"
12DEPENDS = "jpeg libpng freetype zlib tslib sysfsutils"
13
14SRC_URI = "http://www.directfb.org/downloads/Core/DirectFB-1.7/DirectFB-${PV}.tar.gz \
15 file://configurefix.patch \
16 file://fusion.patch \
17 file://bashism.patch \
18 "
19
20S = "${WORKDIR}/DirectFB-${PV}"
21
22LDFLAGS_append =" -lts -lm"
23
24BINCONFIG = "${bindir}/directfb-config"
25
26inherit autotools binconfig-disabled pkgconfig
27
28PACKAGECONFIG ??= ""
29PACKAGECONFIG[jpeg2000] = "--enable-jpeg2000,--disable-jpeg2000,jasper"
30PACKAGECONFIG[drmkms] = "--enable-drmkms,--disable-drmkms,libdrm"
31PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
32PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp"
33
34EXTRA_OECONF = "\
35 --with-gfxdrivers=none \
36 --enable-freetype=yes \
37 --enable-zlib \
38 --disable-imlib2 \
39 --disable-mesa \
40 --disable-sdl \
41 --disable-vnc \
42 --disable-x11 \
43"
44
45#Once -fno-omit-frame-pointer option of gcc is added into TARGET_CLFAGS as default
46#this will cause directfb build failure on x86 arch, so filter out it.
47TARGET_CFLAGS_remove_x86 = "-fno-omit-frame-pointer"
48
49#PACKAGES_DYNAMIC += "^directfb-inputdrivers-.*"
50#
51#python populate_packages_prepend () {
52# inputdrivers_libdir = d.expand('${libdir}/directfb-${RV}/inputdrivers')
53# do_split_packages(d, inputdrivers_libdir, '*.so$', 'directfb-inputdrivers-%s', 'Directfb plugin for %s')
54#}
55
56# NOTE: monolithic packaging for now, should improve that eventually
57
58
59
60FILES_${PN}-dbg += "\
61 ${libdir}/directfb-${RV}/*/*/.debug/*.so \
62 ${libdir}/directfb-${RV}/*/.debug/*.so \
63"
64
65FILES_${PN}-dev += "\
66 ${bindir}/directfb-config \
67 ${libdir}/directfb-${RV}/systems/*.la \
68 ${libdir}/directfb-${RV}/inputdrivers/*.la \
69 ${libdir}/directfb-${RV}/interfaces/*/*.la \
70 ${libdir}/directfb-${RV}/wm/*.la \
71"
72
73FILES_${PN} += "\
74 ${libdir}/directfb-${RV}/systems/*.so \
75 ${libdir}/directfb-${RV}/inputdrivers/*.so \
76 ${libdir}/directfb-${RV}/interfaces/*/*.so \
77 ${libdir}/directfb-${RV}/wm/*.so \
78 ${datadir}/directfb-${PV} \
79"
diff --git a/recipes-graphics/directfb/directfb_1.7.4.bb b/recipes-graphics/directfb/directfb_1.7.4.bb
index 561b1247..8586f0c3 100644
--- a/recipes-graphics/directfb/directfb_1.7.4.bb
+++ b/recipes-graphics/directfb/directfb_1.7.4.bb
@@ -1,4 +1,4 @@
1require recipes-graphics/directfb/directfb.inc 1require directfb.inc
2 2
3RV = "1.7-4" 3RV = "1.7-4"
4 4