diff options
author | André Draszik <andre.draszik@jci.com> | 2019-01-17 14:29:17 +0000 |
---|---|---|
committer | André Draszik <andre.draszik@jci.com> | 2019-01-17 14:29:17 +0000 |
commit | 74df05a7f0fd698cbbe65b9bf925f186891426ca (patch) | |
tree | 169665d86e12f2aa2d6df71a856c1893267972d7 /recipes-graphics | |
parent | 9704df97f08cf5895e2f5bcfb33f1a53d10c7704 (diff) | |
download | meta-freescale-74df05a7f0fd698cbbe65b9bf925f186891426ca.tar.gz |
remove True option to getVar calls
getVar() has been defaulting to expanding by default for
a long time (2016), thus remove the True option from
getVar() calls with a regex search and replace.
Search & replace made using the following command:
sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \
-i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \
| cut -d':' -f1 \
| sort -u)
Signed-off-by: André Draszik <andre.draszik@jci.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 4 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 2 |
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index 8348c1b4..b33780d2 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -82,7 +82,7 @@ PACKAGES =+ "libclc-imx libclc-imx-dev \ | |||
82 | libopenvx-imx libopenvx-imx-dev \ | 82 | libopenvx-imx libopenvx-imx-dev \ |
83 | " | 83 | " |
84 | python __anonymous () { | 84 | python __anonymous () { |
85 | has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT', True) or '0') | 85 | has_vivante_kernel_driver_support = (d.getVar('MACHINE_HAS_VIVANTE_KERNEL_DRIVER_SUPPORT') or '0') |
86 | if has_vivante_kernel_driver_support != '1': | 86 | if has_vivante_kernel_driver_support != '1': |
87 | raise bb.parse.SkipPackage('The kernel of machine needs to have Vivante kernel driver support for this recipe to be used.') | 87 | raise bb.parse.SkipPackage('The kernel of machine needs to have Vivante kernel driver support for this recipe to be used.') |
88 | } | 88 | } |
@@ -102,7 +102,7 @@ SOLIBS = "${SOLIBSDEV}" | |||
102 | python __anonymous() { | 102 | python __anonymous() { |
103 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | 103 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have |
104 | # the source we cannot fix it. Disable the insane check for now. | 104 | # the source we cannot fix it. Disable the insane check for now. |
105 | packages = d.getVar('PACKAGES', True).split() | 105 | packages = d.getVar('PACKAGES').split() |
106 | for p in packages: | 106 | for p in packages: |
107 | d.appendVar("INSANE_SKIP_%s" % p, " ldflags") | 107 | d.appendVar("INSANE_SKIP_%s" % p, " ldflags") |
108 | 108 | ||
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 5ead6251..8541ed7c 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -6,7 +6,7 @@ PACKAGECONFIG_remove_imxgpu3d = "gles" | |||
6 | 6 | ||
7 | # FIXME: mesa should support 'x11-no-tls' option | 7 | # FIXME: mesa should support 'x11-no-tls' option |
8 | python () { | 8 | python () { |
9 | overrides = d.getVar("OVERRIDES", True).split(":") | 9 | overrides = d.getVar("OVERRIDES").split(":") |
10 | if "imxgpu2d" not in overrides: | 10 | if "imxgpu2d" not in overrides: |
11 | return | 11 | return |
12 | 12 | ||