diff options
author | Lauren Post <lauren.post@freescale.com> | 2015-07-24 10:40:47 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-28 23:26:59 -0300 |
commit | 64d8b18601da648875f933c56b6c0fe04a0a7e53 (patch) | |
tree | a301a580ecfdf88c2c498fa9c76583787f9cf3c1 /recipes-graphics | |
parent | 1c0404036573eeeb5c93daca07b27e8ecc7d1643 (diff) | |
download | meta-freescale-64d8b18601da648875f933c56b6c0fe04a0a7e53.tar.gz |
mesa: Support for mx6 without GPUs
Fix to support future mx6 i.MX 6UltraLite which does not have a
GPU. This SoC will use mesa so mesa changes before should be more
SoC specific to allow future mx6 SoC without GPU to use mesa.
Signed-off-by: Lauren Post <lauren.post@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 19 |
1 files changed, 12 insertions, 7 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index ec11097c..6cc7de70 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -1,17 +1,22 @@ | |||
1 | PACKAGECONFIG_remove_mx5 = "egl gles" | 1 | PACKAGECONFIG_remove_mx5 = "egl gles" |
2 | PROVIDES_remove_mx5 = "virtual/libgles1 virtual/libgles2 virtual/egl" | 2 | PROVIDES_remove_mx5 = "virtual/libgles1 virtual/libgles2 virtual/egl" |
3 | 3 | ||
4 | PACKAGECONFIG_remove_mx6 = "egl gles" | 4 | PACKAGECONFIG_remove_mx6q = "egl gles" |
5 | PACKAGECONFIG_remove_mx6dl = "egl gles" | ||
6 | PACKAGECONFIG_remove_mx6sx = "egl gles" | ||
7 | PACKAGECONFIG_remove_mx6sl = "egl gles" | ||
5 | 8 | ||
6 | # i.MX6SL uses mesa software rendering | 9 | # i.MX6SL uses mesa software rendering |
7 | 10 | ||
8 | PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/egl" | 11 | PROVIDES_remove_mx6q = "virtual/libgles1 virtual/libgles2 virtual/egl virtual/libgl" |
9 | PROVIDES_remove_mx6q = "virtual/libgl" | 12 | PROVIDES_remove_mx6dl = "virtual/libgles1 virtual/libgles2 virtual/egl virtual/libgl" |
10 | PROVIDES_remove_mx6dl = "virtual/libgl" | 13 | PROVIDES_remove_mx6sx = "virtual/libgles1 virtual/libgles2 virtual/egl virtual/libgl" |
11 | PROVIDES_remove_mx6sx = "virtual/libgl" | 14 | PROVIDES_remove_mx6sl = "virtual/libgles1 virtual/libgles2 virtual/egl" |
12 | 15 | ||
13 | USE_VIV_LIBGL = "yes" | 16 | USE_VIV_LIBGL = "no" |
14 | USE_VIV_LIBGL_mx6sl = "no" | 17 | USE_VIV_LIBGL_mx6q = "yes" |
18 | USE_VIV_LIBGL_mx6dl = "yes" | ||
19 | USE_VIV_LIBGL_mx6sx = "yes" | ||
15 | 20 | ||
16 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary | 21 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary |
17 | do_install_append_mx6 () { | 22 | do_install_append_mx6 () { |