diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2018-10-10 16:59:32 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2018-11-02 10:36:05 -0500 |
commit | 30d8e9ad3aea13417a73979215412b3df9871d6d (patch) | |
tree | bc63cc4564a01d9113f6b0193425ea2e39f46418 /recipes-graphics | |
parent | 1362b906ed06d702a45523b41dd50747bf9f0557 (diff) | |
download | meta-freescale-30d8e9ad3aea13417a73979215412b3df9871d6d.tar.gz |
imx-gpu-g2d: Upgrade to 6.2.4.p1.8
Adds support for aarch64.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.6.bb | 38 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb | 41 |
2 files changed, 41 insertions, 38 deletions
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.6.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.6.bb deleted file mode 100644 index 85268817..00000000 --- a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.6.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2018 NXP | ||
3 | # Copyright 2018 (C) O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "G2D graphics library and apps for i.MX 6 and i.MX 7 GPU" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab61cab9599935bfe9f700405ef00f28" | ||
9 | |||
10 | DEPENDS += "libgal-imx" | ||
11 | PROVIDES += "virtual/libg2d" | ||
12 | |||
13 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | ||
14 | |||
15 | S="${WORKDIR}/${PN}-${PV}" | ||
16 | |||
17 | inherit fsl-eula-unpack | ||
18 | |||
19 | SRC_URI[md5sum] = "0829288a9b4fcc89066d1671aeb671b9" | ||
20 | SRC_URI[sha256sum] = "5ded476226df9068ec8611b5e89d444de1e5d9a53374a7ea4fb47bc5c6ba20e0" | ||
21 | |||
22 | do_install () { | ||
23 | |||
24 | install -d ${D}${libdir} | ||
25 | install -d ${D}${includedir} | ||
26 | |||
27 | cp ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
28 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
29 | cp -r ${S}/gpu-demos/opt ${D} | ||
30 | } | ||
31 | |||
32 | RDEPENDS_${PN} = "libgal-imx" | ||
33 | |||
34 | FILES_${PN} = "${libdir}/libg2d* /opt" | ||
35 | FILES_${PN}-dev = "${includedir}" | ||
36 | INSANE_SKIP_${PN} = "ldflags" | ||
37 | |||
38 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb new file mode 100644 index 00000000..ab712377 --- /dev/null +++ b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2018 NXP | ||
3 | # Copyright 2018 (C) O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and no DPU" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db" | ||
9 | |||
10 | DEPENDS += "libgal-imx" | ||
11 | PROVIDES += "virtual/libg2d" | ||
12 | |||
13 | # FIXME: arm packages are mis-labeled with aarch32 suffix | ||
14 | FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}" | ||
15 | FSLBIN_NAME_arm = "${PN}-${PV}-aarch32" | ||
16 | |||
17 | SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true" | ||
18 | SRC_URI[arm.md5sum] = "ab7e43c997d3a84764fc3cc72d3b397c" | ||
19 | SRC_URI[arm.sha256sum] = "88b3af3dd109e7c9c457d19441dbb668e7c395d29340d724db3cc42dc04ae87b" | ||
20 | SRC_URI[aarch64.md5sum] = "287f2de4bd407b2eb484d332ae6de157" | ||
21 | SRC_URI[aarch64.sha256sum] = "77f191135f2be6052eabc8cca50b4ea7b5eaec015488cc108fb3f9656a3a1367" | ||
22 | |||
23 | S = "${WORKDIR}/${FSLBIN_NAME}" | ||
24 | |||
25 | inherit fsl-eula-unpack | ||
26 | |||
27 | do_install () { | ||
28 | install -d ${D}${libdir} | ||
29 | install -d ${D}${includedir} | ||
30 | cp ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
31 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
32 | cp -r ${S}/gpu-demos/opt ${D} | ||
33 | } | ||
34 | |||
35 | FILES_${PN} = "${libdir}/libg2d* /opt" | ||
36 | FILES_${PN}-dev = "${includedir}" | ||
37 | INSANE_SKIP_${PN} = "ldflags" | ||
38 | |||
39 | RDEPENDS_${PN} = "libgal-imx" | ||
40 | |||
41 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||