diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2019-09-25 14:38:44 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-10-09 16:35:56 -0300 |
commit | a37ba587b1fd73948e4bc53bfcaaaafd46e8f054 (patch) | |
tree | 00ed67c7aa7d36bd5d4f598321e7c573eb2967b6 /recipes-graphics | |
parent | e7e0a3ebfa6a42e2a65642051a9c18ae90de320d (diff) | |
download | meta-freescale-a37ba587b1fd73948e4bc53bfcaaaafd46e8f054.tar.gz |
mesa-demos: Remove workaround now that eglut_wayland event loop is fixed
The eglut_wayland event loop is properly fixed, so the simple workaround
patch is no longer necessary.
https://gitlab.freedesktop.org/mesa/demos/commit/c539078c5fa592134f6f8a95be51c8eb318f5c39
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/mesa/mesa-demos/Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch | 28 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa-demos_%.bbappend | 1 |
2 files changed, 0 insertions, 29 deletions
diff --git a/recipes-graphics/mesa/mesa-demos/Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch b/recipes-graphics/mesa/mesa-demos/Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch deleted file mode 100644 index 180a9d84..00000000 --- a/recipes-graphics/mesa/mesa-demos/Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 010af1952d935352764389636b7165283e6c9e3f Mon Sep 17 00:00:00 2001 | ||
2 | From: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
3 | Date: Tue, 7 Apr 2015 17:58:45 -0500 | ||
4 | Subject: [PATCH] Additional eglSwapBuffer calling makes wrong throttling | ||
5 | |||
6 | Upstream Status: Pending | ||
7 | |||
8 | Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
9 | --- | ||
10 | src/egl/eglut/eglut_wayland.c | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/egl/eglut/eglut_wayland.c b/src/egl/eglut/eglut_wayland.c | ||
14 | index 968b33f..5664d35 100644 | ||
15 | --- a/src/egl/eglut/eglut_wayland.c | ||
16 | +++ b/src/egl/eglut/eglut_wayland.c | ||
17 | @@ -155,7 +155,7 @@ draw(void *data, struct wl_callback *callback, uint32_t time) | ||
18 | |||
19 | if (win->display_cb) | ||
20 | win->display_cb(); | ||
21 | - eglSwapBuffers(_eglut->dpy, win->surface); | ||
22 | + /*eglSwapBuffers(_eglut->dpy, win->surface);*/ | ||
23 | |||
24 | if (callback) | ||
25 | wl_callback_destroy(callback); | ||
26 | -- | ||
27 | 2.3.5 | ||
28 | |||
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend index 38ccaa38..301f1b59 100644 --- a/recipes-graphics/mesa/mesa-demos_%.bbappend +++ b/recipes-graphics/mesa/mesa-demos_%.bbappend | |||
@@ -2,7 +2,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
2 | 2 | ||
3 | SRC_URI_append_imxgpu = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ | 3 | SRC_URI_append_imxgpu = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ |
4 | file://fix-clear-build-break.patch \ | 4 | file://fix-clear-build-break.patch \ |
5 | file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ | ||
6 | file://Add-OpenVG-demos-to-support-wayland.patch" | 5 | file://Add-OpenVG-demos-to-support-wayland.patch" |
7 | 6 | ||
8 | PACKAGECONFIG_REMOVE_IF_2D_ONLY = "" | 7 | PACKAGECONFIG_REMOVE_IF_2D_ONLY = "" |