diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2021-08-06 16:43:29 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-12 10:08:24 -0700 |
commit | 7377f6c87e351ad702485fee1e9da42690f9f5e8 (patch) | |
tree | e07050278e48824c5e4ef51c210b70cfe093df75 /recipes-graphics | |
parent | 248273e8ade376d389aa862a26284c90d6bdff9d (diff) | |
download | meta-freescale-7377f6c87e351ad702485fee1e9da42690f9f5e8.tar.gz |
layer: More override fixes
Adds fixes for _imx, _imxdpu, _imxdrm, _imxgpu, _imxgpu3d,
virtual PREFERRED_PROVIDER versions
Fix other places for imx/imxdpu/imxdrm overrides
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 2 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston-init.bbappend | 2 | ||||
-rw-r--r-- | recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index e486d689..472c03c4 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -17,7 +17,7 @@ DEPENDS += " \ | |||
17 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb libxshmfence libxxf86vm', \ | 17 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb libxshmfence libxxf86vm', \ |
18 | '', d)} \ | 18 | '', d)} \ |
19 | " | 19 | " |
20 | DEPENDS:append_imxdrm = " libdrm wayland" | 20 | DEPENDS:append:imxdrm = " libdrm wayland" |
21 | DEPENDS:append:mx8 = " patchelf-native" | 21 | DEPENDS:append:mx8 = " patchelf-native" |
22 | 22 | ||
23 | # imx-gpu-viv does not provide everything it needs to for virtual/libgl | 23 | # imx-gpu-viv does not provide everything it needs to for virtual/libgl |
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend index e6baac0b..5710e9b5 100644 --- a/recipes-graphics/wayland/weston-init.bbappend +++ b/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -12,7 +12,7 @@ SRC_URI:append:mx6sl = " file://weston.config" | |||
12 | # commented out. For example: | 12 | # commented out. For example: |
13 | # #xwayland=true | 13 | # #xwayland=true |
14 | # Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. | 14 | # Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. |
15 | INI_UNCOMMENT_ASSIGNMENTS:append_imx = " \ | 15 | INI_UNCOMMENT_ASSIGNMENTS:append:imx = " \ |
16 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ | 16 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ |
17 | " | 17 | " |
18 | INI_UNCOMMENT_ASSIGNMENTS:append:mx8 = " \ | 18 | INI_UNCOMMENT_ASSIGNMENTS:append:mx8 = " \ |
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend index c7b7e879..34e2ed82 100644 --- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend +++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | |||
@@ -13,4 +13,4 @@ IMX_OPENGL_PKGCONFIGS_REMOVE = "" | |||
13 | IMX_OPENGL_PKGCONFIGS_REMOVE:imxgpu = "glamor" | 13 | IMX_OPENGL_PKGCONFIGS_REMOVE:imxgpu = "glamor" |
14 | OPENGL_PKGCONFIGS:remove:mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 14 | OPENGL_PKGCONFIGS:remove:mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
15 | OPENGL_PKGCONFIGS:remove:mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 15 | OPENGL_PKGCONFIGS:remove:mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
16 | OPENGL_PKGCONFIGS:remove_imxdrm = "dri glx" | 16 | OPENGL_PKGCONFIGS:remove:imxdrm = "dri glx" |