summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-02-21 14:53:57 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2022-03-06 11:13:36 +0100
commit9d4e53017385d548aaeec4d8e756ea263c26dc33 (patch)
tree754b4a16fa3de3051cff714b03e8aeba3d1a9cc9 /recipes-graphics
parentf6e0f17d2b777d15d97632055d129a10bd47e525 (diff)
downloadmeta-freescale-9d4e53017385d548aaeec4d8e756ea263c26dc33.tar.gz
xf86-video-imx-vivante: drop vivante specific x11 driver
The required x11 driver stuff has been removed from imx-gpu-viv and thus the X11 driver is no longer buildable. Drop the recipe and fallback on the default X11 fb driver. | ERROR: Nothing RPROVIDES 'libvivante-dri-imx' (but .../meta-freescale/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb RDEPENDS on or otherwise requires it) Completes 747c96f5 ("imx-gpu-viv: Upgrade to 6.4.3.p2.4"). Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imx-vivante/rc.autohdmi42
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb65
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/mx6-nxp-bsp/xorg.conf8
3 files changed, 3 insertions, 112 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imx-vivante/rc.autohdmi b/recipes-graphics/xorg-driver/xf86-video-imx-vivante/rc.autohdmi
deleted file mode 100644
index 8c16a1d7..00000000
--- a/recipes-graphics/xorg-driver/xf86-video-imx-vivante/rc.autohdmi
+++ /dev/null
@@ -1,42 +0,0 @@
1#! /bin/sh
2### BEGIN INIT INFO
3# Provides: rc.autohdmi
4# Required-Start: $all
5# Required-Stop:
6# Default-Start: 2 3 4 5
7# Default-Stop:
8### END INIT INFO
9
10PATH=/sbin:/usr/sbin:/bin:/usr/bin
11
12# Source function library.
13. /etc/init.d/functions
14
15case "$1" in
16 start)
17 echo -n "Starting autohdmi: "
18 export DISPLAY=:0
19 autohdmi &
20 echo
21 exit 0
22 ;;
23 reload|force-reload)
24 echo "Error: argument '$1' not supported" >&2
25 exit 3
26 ;;
27 stop)
28 echo -n "Shutting down autohdmi: "
29 killproc autohdmi
30 echo
31 ;;
32 restart)
33 echo -n "Restarting autohdmi: "
34 $0 stop
35 $0 start
36 echo
37 ;;
38 *)
39 echo "Usage: $0 start|stop" >&2
40 exit 3
41 ;;
42esac
diff --git a/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb b/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb
deleted file mode 100644
index 1a272304..00000000
--- a/recipes-graphics/xorg-driver/xf86-video-imx-vivante_6.4.0.p0.0.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
3# Copyright 2017-2018 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6require recipes-graphics/xorg-driver/xorg-driver-video.inc
7
8PE = "3"
9
10inherit autotools-brokensep update-rc.d pkgconfig
11
12DEPENDS += "virtual/xserver virtual/libx11 libgal-imx imx-gpu-viv virtual/libg2d pixman"
13
14LIC_FILES_CHKSUM = "file://COPYING-MIT;md5=b5e9d9f5c02ea831ab3ecf802bb7c4f3"
15
16SRCREV = "c828e8a7c38743e960967e7bb78c134cec31c102"
17SRCBRANCH = "imx_exa_viv6_g2d"
18SRC_URI = "git://source.codeaurora.org/external/imx/xf86-video-imx-vivante.git;protocol=https;branch=${SRCBRANCH} \
19 file://rc.autohdmi"
20
21S = "${WORKDIR}/git"
22
23INITSCRIPT_PACKAGES = "xserver-xorg-extension-viv-autohdmi"
24INITSCRIPT_NAME = "rc.autohdmi"
25INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
26
27EXTRA_OEMAKE += "prefix=${exec_prefix} \
28 sysroot=${STAGING_DIR_TARGET} \
29 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
30 BUSID_HAS_NUMBER=1 \
31 BUILD_IN_YOCTO=1 \
32 XSERVER_GREATER_THAN_13=1"
33TARGET_CC_ARCH += "${LDFLAGS}"
34
35PACKAGES =+ "xserver-xorg-extension-viv-autohdmi"
36
37do_install:append () {
38 install -d ${D}${includedir}
39 cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir}
40 cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir}
41
42 install -d ${D}/${sysconfdir}/init.d
43 install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi
44
45 find ${D}${includedir} -type f -exec chmod 660 {} \;
46}
47
48RDEPENDS:${PN} += "libvivante-dri-imx \
49 xserver-xorg-module-exa \
50 mesa-driver-swrast \
51 xserver-xorg-extension-dri \
52 xserver-xorg-extension-dri2 \
53 xserver-xorg-extension-glx"
54
55REALSOLIBS := "${SOLIBS}"
56SOLIBS = "${SOLIBSDEV}"
57
58FILES:${PN} = "${libdir}/*/*/*/vivante_drv${SOLIBS}"
59FILES:${PN}-dev = "${includedir} /usr/src ${libdir}/libfsl_x11_ext${SOLIBSDEV}"
60FILES:${PN}-dbg = "${libdir}/*/*/*/.debug ${libdir}/.debug/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/.debug/autohdmi"
61
62FILES:xserver-xorg-extension-viv-autohdmi = " ${libdir}/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/autohdmi ${sysconfdir}/init.d/rc.autohdmi"
63
64PACKAGE_ARCH = "${MACHINE_SOCARCH}"
65COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7ulp-nxp-bsp)"
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/mx6-nxp-bsp/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/mx6-nxp-bsp/xorg.conf
index b89bed60..79b6c0fc 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config/mx6-nxp-bsp/xorg.conf
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/mx6-nxp-bsp/xorg.conf
@@ -1,9 +1,7 @@
1Section "Device" 1Section "Device"
2 Identifier "i.MX Accelerated Framebuffer Device" 2 Identifier "Kernel Framebuffer Device"
3 Driver "vivante" 3 Driver "fbdev"
4 Option "fbdev" "/dev/fb0" 4 Option "fbdev" "/dev/fb0"
5 Option "vivante_fbdev" "/dev/fb0"
6 Option "HWcursor" "false"
7EndSection 5EndSection
8 6
9Section "ServerFlags" 7Section "ServerFlags"