diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2021-02-04 12:55:22 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-02-16 11:46:12 -0300 |
commit | 148581622b1097123f0fdb905c3167d0d6d6f5b7 (patch) | |
tree | 9d1c0c12ee713ea532bc76d8bc10639746af5f8b /recipes-graphics | |
parent | 6078f458b6aa24411a733f4238ef7358183dddaf (diff) | |
download | meta-freescale-148581622b1097123f0fdb905c3167d0d6d6f5b7.tar.gz |
mesa: For i.MX parts without GPU use default gallium and dri
For NXP BSP, building graphics software for a part without GPU can fail with a
dependency issue:
```
ERROR: Nothing RPROVIDES 'libgl' (but /home/r60874/gatesgarth/sources/poky/meta/recipes-gnome/gtk+/gtk+3_3.24.22.bb, /home/r60874/gatesgarth/sources/poky/meta/recipes-graphics/cogl/cogl-1.0_1.22.8.bb RDEPENDS on or otherwise requires it)
```
This is fixed by adding a third case configuration using the default gallium and dri.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 30 |
1 files changed, 20 insertions, 10 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index b6dbcc2f..fce3802e 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -17,16 +17,26 @@ python () { | |||
17 | # Enable Etnaviv and Freedreno support | 17 | # Enable Etnaviv and Freedreno support |
18 | PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" | 18 | PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" |
19 | 19 | ||
20 | # For NXP BSP, disable dri for parts without DRM. | 20 | # For NXP BSP, choose between gallium and osmesa, and between enabling |
21 | # Disable gallium and enable OSMesa for parts with DRM. | 21 | # dri and swrast or not. gallium and dri are default. |
22 | # Also enable swrast for its dri driver for parts with DRM. | 22 | # |
23 | PACKAGECONFIG_REMOVE_NXPBSP = "dri" | 23 | # For parts with no GPU, use gallium and dri |
24 | PACKAGECONFIG_APPEND_NXPBSP = "" | 24 | PACKAGECONFIG_REMOVE_NXPBSP = "" |
25 | PACKAGECONFIG_REMOVE_NXPBSP_imxdrm = "gallium" | 25 | PACKAGECONFIG_APPEND_NXPBSP = "" |
26 | PACKAGECONFIG_APPEND_NXPBSP_imxdrm = "osmesa" | 26 | DRIDRIVERS_NXPBSP = "" |
27 | PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}" | 27 | # |
28 | PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}" | 28 | # For parts with GPU but no DRM, use gallium |
29 | DRIDRIVERS_use-nxp-bsp_imxdrm = "swrast" | 29 | PACKAGECONFIG_REMOVE_NXPBSP_imxgpu = "dri" |
30 | DRIDRIVERS_NXPBSP_imxgpu = "" | ||
31 | # | ||
32 | # For parts with GPU and DRM, use osmesa, dri, and swrast | ||
33 | PACKAGECONFIG_REMOVE_NXPBSP_imxgpu_imxdrm = "gallium" | ||
34 | PACKAGECONFIG_APPEND_NXPBSP_imxgpu_imxdrm = "osmesa" | ||
35 | DRIDRIVERS_NXPBSP_imxgpu_imxdrm = "swrast" | ||
36 | # | ||
37 | PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}" | ||
38 | PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}" | ||
39 | DRIDRIVERS_use-nxp-bsp = "${DRIDRIVERS_NXPBSP}" | ||
30 | 40 | ||
31 | BACKEND = \ | 41 | BACKEND = \ |
32 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | 42 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ |