diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2021-06-26 13:32:08 +0200 |
---|---|---|
committer | Max Krummenacher <max.krummenacher@toradex.com> | 2021-06-26 13:32:08 +0200 |
commit | 3e7163bfa69a09225b03496c4788f2fbda59ef0b (patch) | |
tree | 26821e4193f7e34410a11c3a6fea385e832ee335 /recipes-graphics/xwayland | |
parent | 2684b2270a1dda22816a3bb47738d1fa61223c55 (diff) | |
download | meta-freescale-3e7163bfa69a09225b03496c4788f2fbda59ef0b.tar.gz |
xwayland: fix build against vivante provided opengl on 32bit i.MX
With 'use-nxp-bsp' xwayland must not be configured to use glamour. Set
the now available package configs accordingly.
Prevents compile time errors like:
| ../xwayland-21.1.1/hw/xwayland/xwayland-present.c:61:49: error: invalid application of 'sizeof' to incomplete type 'struct xwl_present_window'
| 61 | xwl_present_window = calloc (1, sizeof (struct xwl_present_window));
...
| ../xwayland-21.1.1/hw/xwayland/xwayland-present.c:450:14: error: implicit declaration of function 'xwl_glamor_pixmap_get_wl_buffer' [-Werror=implicit-function-declaration]
| 450 | buffer = xwl_glamor_pixmap_get_wl_buffer(pixmap);
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/xwayland')
-rw-r--r-- | recipes-graphics/xwayland/xwayland_%.bbappend | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend new file mode 100644 index 00000000..c26bb20d --- /dev/null +++ b/recipes-graphics/xwayland/xwayland_%.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | IMX_OPENGL_PKGCONFIGS_REMOVE = "" | ||
2 | IMX_OPENGL_PKGCONFIGS_REMOVE_imxgpu = "glamor" | ||
3 | OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | ||
4 | OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | ||