diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-17 10:01:30 -0700 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2022-09-20 23:52:02 +0000 |
commit | 047fb6c66a27bbc7fd6f591a1d068731d7cd58de (patch) | |
tree | d8d18f42376c68c551c9fff5beecc3f3a8c85abe /recipes-graphics/xwayland | |
parent | 24f2861a3b6a424c3ca5cf9c255e8875a37d288e (diff) | |
download | meta-freescale-047fb6c66a27bbc7fd6f591a1d068731d7cd58de.tar.gz |
cairo,xwayland: Fix compiling with musl with vivante gpu driver libs
This ensures that the symbols from the prebuilt libs are not flagged
during build, we are betting on gcompat to provide the missing glibc
API stubs at runtime.
Depend on gcompat on musl needed for imxgpu machines its needed
since graphics driver is precompiled for glibc.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
(cherry picked from commit fa4112e43fc4edc4a8521eddd459606328be647e)
Diffstat (limited to 'recipes-graphics/xwayland')
-rw-r--r-- | recipes-graphics/xwayland/xwayland_%.bbappend | 7 |
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend index 69063121..f2141f4f 100644 --- a/recipes-graphics/xwayland/xwayland_%.bbappend +++ b/recipes-graphics/xwayland/xwayland_%.bbappend | |||
@@ -10,3 +10,10 @@ OPENGL_PKGCONFIGS_REMOVE_IMXGPU = "" | |||
10 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" | 10 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" |
11 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" | 11 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" |
12 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" | 12 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" |
13 | |||
14 | |||
15 | # links with imx-gpu libs which are pre-built for glibc | ||
16 | # gcompat will address it during runtime | ||
17 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | ||
18 | |||
19 | RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat" | ||