diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2021-04-07 23:55:04 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-04-20 12:10:12 -0300 |
commit | f5d3b67e3fb463d87588f8c9452f055e5d6f5a51 (patch) | |
tree | fb69608702d12852f70cdce84b6245661245f6ac /recipes-graphics/xorg-xserver | |
parent | 73e068409ffe01d6c52f329f3673cc601773f774 (diff) | |
download | meta-freescale-f5d3b67e3fb463d87588f8c9452f055e5d6f5a51.tar.gz |
xserver-xorg: enable atomic/dri3
Inspired by [1-2]
[1] https://gitlab.freedesktop.org/mesa/mesa/-/issues/4584
[2] https://gitlab.freedesktop.org/mesa/mesa/-/issues/3721
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Vinicius Aquino <voa.aquino@gmail.com>
Diffstat (limited to 'recipes-graphics/xorg-xserver')
3 files changed, 42 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf index c58ae207..0c52ad3b 100644 --- a/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf +++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf | |||
@@ -3,9 +3,11 @@ Section "Device" | |||
3 | Driver "modesetting" | 3 | Driver "modesetting" |
4 | Option "kmsdev" "/dev/dri/card0" | 4 | Option "kmsdev" "/dev/dri/card0" |
5 | Option "AccelMethod" "glamor" | 5 | Option "AccelMethod" "glamor" |
6 | Option "Atomic" "On" | ||
6 | EndSection | 7 | EndSection |
7 | 8 | ||
8 | Section "ServerFlags" | 9 | Section "ServerFlags" |
9 | Option "AutoAddGPU" "false" | 10 | Option "AutoAddGPU" "false" |
11 | Option "DRI" "3" | ||
10 | EndSection | 12 | EndSection |
11 | 13 | ||
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0001-Allow-to-enable-atomic-in-modesetting-DDX.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0001-Allow-to-enable-atomic-in-modesetting-DDX.patch new file mode 100644 index 00000000..caf2fcd6 --- /dev/null +++ b/recipes-graphics/xorg-xserver/xserver-xorg/0001-Allow-to-enable-atomic-in-modesetting-DDX.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 9c8b815520bf52caf780dc4defea0fe2fe8e33a3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Daniel Abrecht <public@danielabrecht.ch> | ||
3 | Date: Wed, 21 Oct 2020 21:13:30 +0200 | ||
4 | Subject: [PATCH] Allow to enable atomic in modesetting DDX | ||
5 | |||
6 | The linux kernel blacklisted atomic for the modesetting DDX to deal with | ||
7 | problems with old Xorg versions which didn't have it disabled by default. | ||
8 | Ever since, it wasn't possible to enable atomic in modesetting at all | ||
9 | anymore. | ||
10 | |||
11 | This change doesn't enable atomic by default, but it allows a user to | ||
12 | enabled it again. | ||
13 | |||
14 | Signed-off-by: Daniel Abrecht <public@danielabrecht.ch> | ||
15 | --- | ||
16 | hw/xfree86/drivers/modesetting/driver.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/hw/xfree86/drivers/modesetting/driver.c b/hw/xfree86/drivers/modesetting/driver.c | ||
20 | index 6549ef8e1..bd8576f81 100644 | ||
21 | --- a/hw/xfree86/drivers/modesetting/driver.c | ||
22 | +++ b/hw/xfree86/drivers/modesetting/driver.c | ||
23 | @@ -1216,7 +1216,7 @@ PreInit(ScrnInfoPtr pScrn, int flags) | ||
24 | } | ||
25 | |||
26 | if (xf86ReturnOptValBool(ms->drmmode.Options, OPTION_ATOMIC, FALSE)) { | ||
27 | - ret = drmSetClientCap(ms->fd, DRM_CLIENT_CAP_ATOMIC, 1); | ||
28 | + ret = drmSetClientCap(ms->fd, DRM_CLIENT_CAP_ATOMIC, 2); | ||
29 | ms->atomic_modeset = (ret == 0); | ||
30 | } else { | ||
31 | ms->atomic_modeset = FALSE; | ||
32 | -- | ||
33 | GitLab | ||
34 | |||
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend index a828e518..68c6d2d2 100644 --- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend +++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | |||
@@ -11,4 +11,10 @@ IMX_OPENGL_PKGCONFIGS_REMOVE = "" | |||
11 | IMX_OPENGL_PKGCONFIGS_REMOVE_imxgpu = "glamor" | 11 | IMX_OPENGL_PKGCONFIGS_REMOVE_imxgpu = "glamor" |
12 | OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 12 | OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
13 | OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 13 | OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
14 | OPENGL_PKGCONFIGS_remove_mx8 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | ||
14 | OPENGL_PKGCONFIGS_remove_imxdrm = "dri glx" | 15 | OPENGL_PKGCONFIGS_remove_imxdrm = "dri glx" |
16 | |||
17 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" | ||
18 | SRC_URI_append_imxgpu2d = " file://0003-Remove-check-for-useSIGIO-option.patch" | ||
19 | SRC_URI_append_use-mainline-bsp = " file://0001-Allow-to-enable-atomic-in-modesetting-DDX.patch" | ||
20 | |||