diff options
author | Neena Busireddy <neenareddy.busireddy@nxp.com> | 2019-02-22 16:03:02 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-06-24 17:13:00 -0300 |
commit | b504c047698c4b74a859c5f23d654f348449c179 (patch) | |
tree | 5dfb5a6f7be5e6550ddf40c734c9abad25f6e76a /recipes-graphics/xorg-xserver | |
parent | a8f3d5749e69c5a64d7dd179d367159763b898ab (diff) | |
download | meta-freescale-b504c047698c4b74a859c5f23d654f348449c179.tar.gz |
xserver-xorg: Fix X server 1.20.1 crash [YOCIMX-3280]
One of our patches which we upstreamed has been removed from the poky thud.
http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/meta/recipes-graphics/xorg-xserver?h=thud&id=9d2cbf041403f5012b251de6c2dc0683755398ed
Add the patch back to fix the crash.
Signed-off-by: Neena Busireddy <neenareddy.busireddy@nxp.com>
Backport from https://source.codeaurora.org/external/imx/meta-fsl-bsp-release/commit/imx/meta-bsp/recipes-graphics/xorg-xserver?h=thud-4.19.35-1.0.0&id=7b9dbcf65929446ddbd5c8245617a624eb30b9ff
Limit the patch to machines which use xf86-video-imx-vivante.
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/xorg-xserver')
-rw-r--r-- | recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch | 47 | ||||
-rw-r--r-- | recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | 3 |
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch new file mode 100644 index 00000000..beed6cb4 --- /dev/null +++ b/recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | From cf407b16cd65ad6e26a9c8e5984e163409a5c0f7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Prabhu Sundararaj <prabhu.sundararaj@nxp.com> | ||
3 | Date: Mon, 30 Jan 2017 16:32:06 -0600 | ||
4 | Subject: [PATCH] Remove check for useSIGIO option | ||
5 | |||
6 | Commit 6a5a4e60373c1386b311b2a8bb666c32d68a9d99 removes the configure of useSIGIO | ||
7 | option. | ||
8 | |||
9 | As the xfree86 SIGIO support is reworked to use internal versions of OsBlockSIGIO | ||
10 | and OsReleaseSIGIO. | ||
11 | |||
12 | No longer the check for useSIGIO is needed | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | |||
16 | Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@nxp.com> | ||
17 | --- | ||
18 | hw/xfree86/os-support/shared/sigio.c | 6 ------ | ||
19 | 1 file changed, 6 deletions(-) | ||
20 | |||
21 | diff --git a/hw/xfree86/os-support/shared/sigio.c b/hw/xfree86/os-support/shared/sigio.c | ||
22 | index 884a71c..be76498 100644 | ||
23 | --- a/hw/xfree86/os-support/shared/sigio.c | ||
24 | +++ b/hw/xfree86/os-support/shared/sigio.c | ||
25 | @@ -185,9 +185,6 @@ xf86InstallSIGIOHandler(int fd, void (*f) (int, void *), void *closure) | ||
26 | int i; | ||
27 | int installed = FALSE; | ||
28 | |||
29 | - if (!xf86Info.useSIGIO) | ||
30 | - return 0; | ||
31 | - | ||
32 | for (i = 0; i < MAX_FUNCS; i++) { | ||
33 | if (!xf86SigIOFuncs[i].f) { | ||
34 | if (xf86IsPipe(fd)) | ||
35 | @@ -256,9 +253,6 @@ xf86RemoveSIGIOHandler(int fd) | ||
36 | int max; | ||
37 | int ret; | ||
38 | |||
39 | - if (!xf86Info.useSIGIO) | ||
40 | - return 0; | ||
41 | - | ||
42 | max = 0; | ||
43 | ret = 0; | ||
44 | for (i = 0; i < MAX_FUNCS; i++) { | ||
45 | -- | ||
46 | 2.7.4 | ||
47 | |||
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend index e3c59040..5762f0f0 100644 --- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend +++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend | |||
@@ -3,3 +3,6 @@ IMX_OPENGL_PKGCONFIGS_REMOVE_imxgpu = "glamor" | |||
3 | OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 3 | OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
4 | OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 4 | OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
5 | OPENGL_PKGCONFIGS_remove_mx8 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" | 5 | OPENGL_PKGCONFIGS_remove_mx8 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" |
6 | |||
7 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" | ||
8 | SRC_URI_append_imxgpu2d = "file://0003-Remove-check-for-useSIGIO-option.patch" | ||