diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2018-06-18 14:57:02 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-06-26 14:19:02 -0300 |
commit | 0085f26566058a926cebf61234e85e78d5c46f71 (patch) | |
tree | de8a8c3a6ee3f2ebca9ce911c092ad4ad0febb7e /recipes-graphics/xorg-driver | |
parent | 17b10e3ebd217faaadd9ff3a08a0099c8ba83a00 (diff) | |
download | meta-freescale-0085f26566058a926cebf61234e85e78d5c46f71.tar.gz |
xf86-video-imxfb-vivante: Update to version 6.2.4.p1.2
- Remove .inc file to use only one .bb file
- Update O.S. Systems License
- Remove unused patch
- Set SDKTARGETSYSROOT to use STAGING_DIR_HOST
- Remove unnecessary CFLAGS
Change-Id: I5c6c56fe2ad3bd12aa13cdc426ba6f34f441d4b7
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/xorg-driver')
-rw-r--r-- | recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Stop-using-Git-to-write-local-version.patch | 87 | ||||
-rw-r--r-- | recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb | 9 | ||||
-rw-r--r-- | recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.4.p1.2.bb (renamed from recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc) | 34 |
3 files changed, 13 insertions, 117 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Stop-using-Git-to-write-local-version.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Stop-using-Git-to-write-local-version.patch deleted file mode 100644 index f541e5c1..00000000 --- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Stop-using-Git-to-write-local-version.patch +++ /dev/null | |||
@@ -1,87 +0,0 @@ | |||
1 | From 69a92f4576a1e789ba2fcf957164d2c4013020c5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Wed, 2 Dec 2015 13:36:25 +0000 | ||
4 | Subject: [PATCH] Stop using Git to write local version | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | The standard version does not use a Git repository so we should not | ||
8 | use Git to identify the commit of the build as it can end getting the | ||
9 | version from a wrong repository and can be misleading. | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
14 | --- | ||
15 | EXA/src/makefile.tc | 6 +++--- | ||
16 | FslExt/src/makefile.tc | 6 +++--- | ||
17 | util/autohdmi/makefile.tc | 6 +++--- | ||
18 | util/pandisplay/makefile.tc | 6 +++--- | ||
19 | 4 files changed, 12 insertions(+), 12 deletions(-) | ||
20 | |||
21 | diff --git a/EXA/src/makefile.tc b/EXA/src/makefile.tc | ||
22 | index 0b9a9e6..ec6e68d 100644 | ||
23 | --- a/EXA/src/makefile.tc | ||
24 | +++ b/EXA/src/makefile.tc | ||
25 | @@ -52,8 +52,8 @@ prefix ?= /usr | ||
26 | sysroot ?= / | ||
27 | |||
28 | # get git commit number | ||
29 | -COMMITNR := `git log -n 1 --format=%H` | ||
30 | -DIRTY := `git diff-index --quiet HEAD || echo '-dirty'` | ||
31 | -LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}" | ||
32 | +#COMMITNR := `git log -n 1 --format=%H` | ||
33 | +#DIRTY := `git diff-index --quiet HEAD || echo '-dirty'` | ||
34 | +#LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}" | ||
35 | |||
36 | |||
37 | diff --git a/FslExt/src/makefile.tc b/FslExt/src/makefile.tc | ||
38 | index 0b9a9e6..ec6e68d 100644 | ||
39 | --- a/FslExt/src/makefile.tc | ||
40 | +++ b/FslExt/src/makefile.tc | ||
41 | @@ -52,8 +52,8 @@ prefix ?= /usr | ||
42 | sysroot ?= / | ||
43 | |||
44 | # get git commit number | ||
45 | -COMMITNR := `git log -n 1 --format=%H` | ||
46 | -DIRTY := `git diff-index --quiet HEAD || echo '-dirty'` | ||
47 | -LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}" | ||
48 | +#COMMITNR := `git log -n 1 --format=%H` | ||
49 | +#DIRTY := `git diff-index --quiet HEAD || echo '-dirty'` | ||
50 | +#LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}" | ||
51 | |||
52 | |||
53 | diff --git a/util/autohdmi/makefile.tc b/util/autohdmi/makefile.tc | ||
54 | index c9de0a6..d0a468c 100644 | ||
55 | --- a/util/autohdmi/makefile.tc | ||
56 | +++ b/util/autohdmi/makefile.tc | ||
57 | @@ -64,8 +64,8 @@ prefix ?= /usr | ||
58 | sysroot ?= / | ||
59 | |||
60 | # get git commit number | ||
61 | -COMMITNR := `git log -n 1 --format=%H` | ||
62 | -DIRTY := `git diff-index --quiet HEAD || echo '-dirty'` | ||
63 | -LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}" | ||
64 | +#COMMITNR := `git log -n 1 --format=%H` | ||
65 | +#DIRTY := `git diff-index --quiet HEAD || echo '-dirty'` | ||
66 | +#LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}" | ||
67 | |||
68 | |||
69 | diff --git a/util/pandisplay/makefile.tc b/util/pandisplay/makefile.tc | ||
70 | index 28732b9..bf54c20 100644 | ||
71 | --- a/util/pandisplay/makefile.tc | ||
72 | +++ b/util/pandisplay/makefile.tc | ||
73 | @@ -64,8 +64,8 @@ prefix ?= /usr | ||
74 | sysroot ?= / | ||
75 | |||
76 | # get git commit number | ||
77 | -COMMITNR := `git log -n 1 --format=%H` | ||
78 | -DIRTY := `git diff-index --quiet HEAD || echo '-dirty'` | ||
79 | -LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}" | ||
80 | +#COMMITNR := `git log -n 1 --format=%H` | ||
81 | +#DIRTY := `git diff-index --quiet HEAD || echo '-dirty'` | ||
82 | +#LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}" | ||
83 | |||
84 | |||
85 | -- | ||
86 | 2.1.4 | ||
87 | |||
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb deleted file mode 100644 index 5514962f..00000000 --- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | # Copyright (C) 2012-2016 Freescale Semiconductor | ||
2 | # Copyright (C) 2012-2014 O.S. Systems Software LTDA. | ||
3 | # Copyright 2017 NXP | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | require xf86-video-imxfb-vivante.inc | ||
7 | |||
8 | SRCBRANCH = "nxp/imx_4.9.11_1.0.0_ga" | ||
9 | SRCREV = "07ef065dfe09f1c05a1a188c371577faa3677a17" | ||
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.4.p1.2.bb index c16da671..04ae36cf 100644 --- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc +++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.4.p1.2.bb | |||
@@ -1,5 +1,6 @@ | |||
1 | # Copyright (C) 2012-2015 Freescale Semiconductor | 1 | # Copyright (C) 2012-2016 Freescale Semiconductor |
2 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. | 2 | # Copyright (C) 2012-2018 O.S. Systems Software LTDA. |
3 | # Copyright 2017-2018 NXP | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | 4 | # Released under the MIT license (see COPYING.MIT for the terms) |
4 | 5 | ||
5 | require recipes-graphics/xorg-driver/xorg-driver-video.inc | 6 | require recipes-graphics/xorg-driver/xorg-driver-video.inc |
@@ -12,6 +13,8 @@ DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv virtua | |||
12 | 13 | ||
13 | LIC_FILES_CHKSUM = "file://COPYING-MIT;md5=b5e9d9f5c02ea831ab3ecf802bb7c4f3" | 14 | LIC_FILES_CHKSUM = "file://COPYING-MIT;md5=b5e9d9f5c02ea831ab3ecf802bb7c4f3" |
14 | 15 | ||
16 | SRCREV = "946e8603ed9a52f36d305405dbb2ab8ff90943d0" | ||
17 | SRCBRANCH = "imx_exa_viv6_g2d" | ||
15 | SRC_URI = "git://source.codeaurora.org/external/imx/xf86-video-imx-vivante.git;protocol=https;branch=${SRCBRANCH} \ | 18 | SRC_URI = "git://source.codeaurora.org/external/imx/xf86-video-imx-vivante.git;protocol=https;branch=${SRCBRANCH} \ |
16 | file://rc.autohdmi" | 19 | file://rc.autohdmi" |
17 | 20 | ||
@@ -21,36 +24,25 @@ INITSCRIPT_PACKAGES = "xserver-xorg-extension-viv-autohdmi" | |||
21 | INITSCRIPT_NAME = "rc.autohdmi" | 24 | INITSCRIPT_NAME = "rc.autohdmi" |
22 | INITSCRIPT_PARAMS = "start 99 2 3 4 5 ." | 25 | INITSCRIPT_PARAMS = "start 99 2 3 4 5 ." |
23 | 26 | ||
24 | EXTRA_OEMAKE += "prefix=${D}/usr \ | 27 | EXTRA_OEMAKE += "prefix=${exec_prefix} \ |
25 | sysroot=${STAGING_DIR_TARGET} \ | 28 | sysroot=${STAGING_DIR_TARGET} \ |
29 | SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ | ||
26 | LFLAGS="${LDFLAGS}" \ | 30 | LFLAGS="${LDFLAGS}" \ |
27 | BUSID_HAS_NUMBER=1 \ | 31 | BUSID_HAS_NUMBER=1 \ |
28 | BUILD_IN_YOCTO=1 \ | 32 | BUILD_IN_YOCTO=1 \ |
29 | XSERVER_GREATER_THAN_13=1" | 33 | XSERVER_GREATER_THAN_13=1" |
30 | 34 | ||
31 | CFLAGS += "-I${STAGING_INCDIR}/xorg \ | ||
32 | -I${STAGING_INCDIR}/drm \ | ||
33 | -I../../DRI_1.10.4/src" | ||
34 | |||
35 | PACKAGES =+ "xserver-xorg-extension-viv-autohdmi" | 35 | PACKAGES =+ "xserver-xorg-extension-viv-autohdmi" |
36 | 36 | ||
37 | # FIXME: The Freescale provided Makefile has hardcodec include paths | ||
38 | # and this does not work in case prefix is different than /usr, | ||
39 | # sed it. | ||
40 | do_configure_prepend () { | ||
41 | sed -i 's,$(sysroot)/usr/include,${STAGING_INCDIR},g' \ | ||
42 | ${S}EXA/src/makefile.linux | ||
43 | } | ||
44 | |||
45 | do_install_append () { | 37 | do_install_append () { |
46 | install -d ${D}${includedir} | 38 | install -d ${D}${includedir} |
47 | cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir} | 39 | cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir} |
48 | cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir} | 40 | cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir} |
49 | 41 | ||
50 | install -d ${D}/${sysconfdir}/init.d | 42 | install -d ${D}/${sysconfdir}/init.d |
51 | install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi | 43 | install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi |
52 | 44 | ||
53 | find ${D}${includedir} -type f -exec chmod 660 {} \; | 45 | find ${D}${includedir} -type f -exec chmod 660 {} \; |
54 | } | 46 | } |
55 | 47 | ||
56 | RDEPENDS_${PN} += "libvivante-dri-imx \ | 48 | RDEPENDS_${PN} += "libvivante-dri-imx \ |