summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-driver/xf86-video-armada_git.bb
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2017-05-27 01:11:08 -0400
committerOtavio Salvador <otavio@ossystems.com.br>2017-05-30 20:09:17 -0300
commitfb1e35f084b684f345854b156b1ff83645c31ed0 (patch)
tree2f8f7cccf9f18d65e10c8abab1b73ae001a4ee81 /recipes-graphics/xorg-driver/xf86-video-armada_git.bb
parent2fa9cd5e34095388ba0db350d07e26147a4f15c9 (diff)
downloadmeta-freescale-fb1e35f084b684f345854b156b1ff83645c31ed0.tar.gz
xf86-video-armada: add
If the user enables "use-mainline-bsp" in MACHINEOVERRIDES, assume they want to use the open-source, reverse-engineered etnaviv drm x11 driver. Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/xorg-driver/xf86-video-armada_git.bb')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-armada_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-armada_git.bb b/recipes-graphics/xorg-driver/xf86-video-armada_git.bb
new file mode 100644
index 00000000..4caebb11
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-armada_git.bb
@@ -0,0 +1,46 @@
1SUMMARY = "X.org graphics driver for KMS based systems with pluggable GPU backend"
2DESCRIPTION = "The xf86-video-armada module is a 2D graphics driver for the X Window \
3System as implemented by X.org, supporting these DRM KMS drivers: \
4\
5 Freescale i.MX \
6 Marvell Armada 510 (Dove) \
7\
8and GPU drivers: \
9 Vivante libGAL (Armada only) \
10 Etnaviv (Armada and i.MX) with galcore kernel driver \
11 Etnaviv (Armada and i.MX) with etnaviv DRM kernel driver \
12"
13LICENSE = "BSD"
14
15require recipes-graphics/xorg-driver/xorg-driver-video.inc
16
17DEPENDS += "libdrm-armada"
18
19LIC_FILES_CHKSUM = " \
20 file://README;md5=d5271074fb6ad959b7b6cfa68b4adaf0 \
21 file://../etna_viv/LICENSE;md5=9d4853905d85f044ed013e75def30a76 \
22 "
23
24SRCREV_armada = "a4306d971717a2d3ea855d08c5667e02403b84fe"
25SRCREV_etna = "f64d77abbb54433bd5de955c20afddc6eb4f4cb1"
26SRCREV_FORMAT = "armada_etna"
27
28PV = "0.1+git${SRCPV}"
29
30SRC_URI = " \
31 git://git.arm.linux.org.uk/cgit/xf86-video-armada.git;branch=unstable-devel;protocol=http;name=armada \
32 git://github.com/laanwj/etna_viv.git;protocol=https;name=etna;destsuffix=etna_viv \
33 "
34
35S = "${WORKDIR}/git"
36
37RDEPENDS_${PN} = "xserver-xorg-module-exa \
38 xserver-xorg-extension-dri \
39 xserver-xorg-extension-dri2 \
40 xserver-xorg-extension-glx \
41 "
42
43EXTRA_OECONF = "--disable-etnaviv \
44 --disable-vivante \
45 --with-etnaviv-source=${WORKDIR}/etna_viv \
46 "