diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2018-07-17 13:24:03 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-08-30 21:57:08 -0300 |
commit | 327fec627201f90788f4c381253096435e612068 (patch) | |
tree | 73bc580fb20bfd9b357e46b2b6cad3280802c31d /recipes-graphics/wayland | |
parent | 9a9d63ae1f452a182a35b8eefae8e3c08f0523f1 (diff) | |
download | meta-freescale-327fec627201f90788f4c381253096435e612068.tar.gz |
weston: Fix non-GPU support
The desktop failed to start on i.MX parts without GPU. The problem
is fixed, and now the package must be configured for i.MX GPU
support.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r-- | recipes-graphics/wayland/weston_4.0.0.imx.bb | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston_4.0.0.imx.bb b/recipes-graphics/wayland/weston_4.0.0.imx.bb index fc6a65f7..7a2aab60 100644 --- a/recipes-graphics/wayland/weston_4.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_4.0.0.imx.bb | |||
@@ -15,7 +15,7 @@ SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=http | |||
15 | file://xwayland.weston-start \ | 15 | file://xwayland.weston-start \ |
16 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ | 16 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ |
17 | " | 17 | " |
18 | SRCREV = "bf74309dd16d86537ff07eabf8b499cb2d25277d" | 18 | SRCREV = "642006cbd89e7ae51a7ce672c899614814dc4ef0" |
19 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
20 | 20 | ||
21 | UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" | 21 | UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" |
@@ -48,6 +48,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev | |||
48 | ${@bb.utils.filter('DISTRO_FEATURES', 'opengl pam systemd x11', d)} \ | 48 | ${@bb.utils.filter('DISTRO_FEATURES', 'opengl pam systemd x11', d)} \ |
49 | clients launch" | 49 | clients launch" |
50 | PACKAGECONFIG_remove_imxfbdev = "kms" | 50 | PACKAGECONFIG_remove_imxfbdev = "kms" |
51 | PACKAGECONFIG_append_imxgpu = " imxgpu" | ||
51 | PACKAGECONFIG_append_imxgpu2d = " imxg2d" | 52 | PACKAGECONFIG_append_imxgpu2d = " imxg2d" |
52 | PACKAGECONFIG_append_imxgpu3d = " cairo-glesv2" | 53 | PACKAGECONFIG_append_imxgpu3d = " cairo-glesv2" |
53 | # | 54 | # |
@@ -85,6 +86,8 @@ PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord" | |||
85 | PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients" | 86 | PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients" |
86 | # Weston with PAM support | 87 | # Weston with PAM support |
87 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" | 88 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" |
89 | # Weston with i.MX GPU support | ||
90 | PACKAGECONFIG[imxgpu] = "--enable-imxgpu,--disable-imxgpu" | ||
88 | # Weston with i.MX G2D renderer | 91 | # Weston with i.MX G2D renderer |
89 | PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d" | 92 | PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d" |
90 | # Weston with OpenGL support | 93 | # Weston with OpenGL support |