summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
authorChris Dimich <Chris.Dimich@boundarydevices.com>2021-05-18 11:32:16 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2021-05-19 08:53:17 -0300
commit4a61fdbd50e6200239dcb0b936bb37acaab2b9e0 (patch)
tree1e39cd15d0bb35f3dd69f31274f9d87e7c05b044 /recipes-graphics/wayland
parent2c4efeea83b9edeb63167ed79163c1e55baab7e6 (diff)
downloadmeta-freescale-4a61fdbd50e6200239dcb0b936bb37acaab2b9e0.tar.gz
weston-init: uncomment use-g2d=1 based on imxgpu2d MACHINEOVERRIDE
affects the following SoCs: -mx6q -mx6dl -mx6sx -mx6sl -mx7ulp -mx8qm -mx8mm -mx8mp -mx8qxp Signed-off-by: Chris Dimich <Chris.Dimich@boundarydevices.com>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend25
1 files changed, 10 insertions, 15 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 66e148c1..ebd98268 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -15,30 +15,25 @@ SRC_URI_append_mx6sl = " file://weston.config"
15INI_UNCOMMENT_ASSIGNMENTS_append_imx = " \ 15INI_UNCOMMENT_ASSIGNMENTS_append_imx = " \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ 16 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \
17" 17"
18INI_UNCOMMENT_ASSIGNMENTS_append_mx6dl = " \
19 use-g2d=1 \
20"
21INI_UNCOMMENT_ASSIGNMENTS_append_mx6q = " \
22 use-g2d=1 \
23"
24INI_UNCOMMENT_ASSIGNMENTS_append_mx7ulp = " \
25 use-g2d=1 \
26"
27INI_UNCOMMENT_ASSIGNMENTS_append_mx8 = " \ 18INI_UNCOMMENT_ASSIGNMENTS_append_mx8 = " \
28 repaint-window=16 \ 19 repaint-window=16 \
29" 20"
30INI_UNCOMMENT_ASSIGNMENTS_append_mx8mm = " \
31 use-g2d=1 \
32"
33INI_UNCOMMENT_ASSIGNMENTS_append_mx8mp = " \
34 use-g2d=1 \
35"
36INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \ 21INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \
37 gbm-format=argb8888 \ 22 gbm-format=argb8888 \
38 \\[shell\\] \ 23 \\[shell\\] \
39 size=1920x1080 \ 24 size=1920x1080 \
40" 25"
41 26
27# FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it
28# Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest
29# rendering code.
30INI_UNCOMMENT_USE_G2D_imxgpu2d ?= "use-g2d=1"
31INI_UNCOMMENT_USE_G2D_mx8qm = ""
32INI_UNCOMMENT_USE_G2D_mx8qxp = ""
33INI_UNCOMMENT_ASSIGNMENTS_append_imxgpu2d = " \
34 ${INI_UNCOMMENT_USE_G2D} \
35"
36
42uncomment() { 37uncomment() {
43 if ! grep -q "^#$1" $2 && ! grep -q "^$1" $2; then 38 if ! grep -q "^#$1" $2 && ! grep -q "^$1" $2; then
44 bbwarn "Commented setting '#$1' not found in file $2" 39 bbwarn "Commented setting '#$1' not found in file $2"