summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-09 13:31:28 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2019-09-21 20:55:30 -0300
commitb61675eccc5ac3cf73f9e24bc651a08ab37110de (patch)
treef2562743f3bf7cd49c5e7e2295ce40b3db8b51bf /recipes-graphics/wayland
parentbacf6dd96784a814b6a0ec48d7de1f783ffaae52 (diff)
downloadmeta-freescale-b61675eccc5ac3cf73f9e24bc651a08ab37110de.tar.gz
weston-init: Adjust to match recent oe-core changes
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend5
-rw-r--r--recipes-graphics/wayland/weston-init/weston.service38
2 files changed, 0 insertions, 43 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 76aadf94..13818bc3 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -13,11 +13,6 @@ HAS_XWAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland x11', 'true', '
13 13
14do_install_append() { 14do_install_append() {
15 if ${HAS_SYSTEMD}; then 15 if ${HAS_SYSTEMD}; then
16 sed -i \
17 -e 's,/usr/bin,${bindir},g' \
18 -e 's,/etc,${sysconfdir},g' \
19 -e 's,/var,${localstatedir},g' \
20 ${D}${systemd_system_unitdir}/weston.service
21 if ${HAS_XWAYLAND}; then 16 if ${HAS_XWAYLAND}; then
22 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston 17 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston
23 fi 18 fi
diff --git a/recipes-graphics/wayland/weston-init/weston.service b/recipes-graphics/wayland/weston-init/weston.service
deleted file mode 100644
index 44c5a82f..00000000
--- a/recipes-graphics/wayland/weston-init/weston.service
+++ /dev/null
@@ -1,38 +0,0 @@
1[Unit]
2Description=Weston Wayland Compositor (on tty7)
3RequiresMountsFor=/run
4Conflicts=getty@tty7.service plymouth-quit.service
5After=systemd-user-sessions.service getty@tty7.service plymouth-quit-wait.service
6
7[Service]
8User=root
9PermissionsStartOnly=true
10
11# Log us in via PAM so we get our XDG & co. environment and
12# are treated as logged in so we can use the tty:
13PAMName=login
14
15# Grab tty7
16UtmpIdentifier=tty7
17TTYPath=/dev/tty7
18TTYReset=yes
19TTYVHangup=yes
20TTYVTDisallocate=yes
21
22# stderr to journal so our logging doesn't get thrown into /dev/null
23StandardOutput=tty
24StandardInput=tty
25StandardError=journal
26
27EnvironmentFile=-/etc/default/weston
28
29# Weston does not successfully change VT, nor does systemd place us on
30# the VT it just activated for us. Switch manually:
31ExecStartPre=/usr/bin/chvt 7
32ExecStart=/usr/bin/weston-launch -- --log=/var/log/weston.log $OPTARGS
33
34IgnoreSIGPIPE=no
35
36[Install]
37WantedBy=multi-user.target
38